【POJ 1742】【Coins】

题目:

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch. 
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins. 

Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4

题意分析:就是给我们n,m, n是金币价值和其数目的种类数,m是1-m范围,问我们1-m这个范围内,在给定的货币和数目情况下,我们能有多少种值出现。

解题思路:多重背包,每个物品多放进去,在数目没有超的情况下,标记一下,然后继续类推。

ac代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;

int dp[100005];
int sum[100005];
int v[105],c[105];

int main()
{
	int i,j,k,n,m;
	while(scanf("%d%d",&n,&m),n+m)
	{
		for(i=1;i<=n;i++)
			scanf("%d",&v[i]);
		for(i=1;i<=n;i++)
			scanf("%d",&c[i]);
		memset(dp,0,sizeof(dp));
		dp[0]=1;//这里的dp数组起到的是标记的作用 
		int ans=0;//记录组合数量 
		for(i=1;i<=n;i++)
		{
			memset(sum,0,sizeof(sum));
			for(j=v[i];j<=m;j++)//多重背包 
			{
				if(!dp[j]&&dp[j-v[i]]&&sum[j-v[i]]<c[i])
				{//在这个组合没出现过,且和它差v[i]的出现了,并且v[i]数目没有用完 
					dp[j]=1;
					sum[j]=sum[j-v[i]]+1;
					ans++;
				}
			}	
		}
		printf("%d\n",ans);	
	}	
	return 0;
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值