【Minimal coverage】【UVA - 10020】(区间排序,cmp)

题目:

Given several segments of line (int the X axis) with coordinates [Li , Ri ]. You are to choose the minimal amount of them, such they would completely cover the segment [0, M].

Input

The first line is the number of test cases, followed by a blank line.

Each test case in the input should contains an integer M (1 ≤ M ≤ 5000), followed by pairs “Li Ri” (|Li |, |Ri | ≤ 50000, i ≤ 100000), each on a separate line. Each test case of input is terminated by pair ‘0 0’.

Each test case will be separated by a single line.

Output

For each test case, in the first line of output your programm should print the minimal number of line segments which can cover segment [0, M]. In the following lines, the coordinates of segments, sorted by their left end (Li), should be printed in the same format as in the input. Pair ‘0 0’ should not be printed. If [0, M] can not be covered by given line segments, your programm should print ‘0’ (without quotes).

Print a blank line between the outputs for two consecutive test cases.

Sample Input

2

1

-1 0

-5 -3

2 5

0 0

1

-1 0

0 1

0 0

Sample Output

0

 

1

0 1

 

解题报告:最小区间覆盖问题,给定咱们一个数字m,问是否存在有限个线段,能够将它完全覆盖。

解题的思路就是:先筛出去右端点小于0的和左端点大于m的,然后看看是否有左端点小于0的或者右端点大于m的,如果有的话就可以继续寻找,按照x的第一升序,y的第二升序排列,看看有无这种线段,有的话,按照y的升序排列,之后存放到数组里,更新最右端点。依次进行,最后能够实现全部的线段查询完毕。

ac代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;

const int maxn =1e6+100;

struct node{
	int x,y;
}pot[maxn];

bool cmp(node a,node b)
{
	if(a.x==b.x)
		return a.y<b.y;
	else
		return a.x<b.x;
}
bool cmp1(node a,node b)
{
	return a.y<b.y;
}
int num[maxn*2];

int main()
{
	int t,m,i;
	cin>>t;
	while(t--)
	{
		int cnt=0;
		int flagx=0,flagy=0;
		int mcnt=0;
		scanf("%d",&m);
		for(cnt=0;;cnt++)
		{
			scanf("%d%d",&pot[cnt].x,&pot[cnt].y);
			if(!pot[cnt].x&&!pot[cnt].y)
				break;
			if(pot[cnt].y<=0||pot[cnt].x>=m)
				cnt--;
			else
			{
				if(pot[cnt].x<=0)
					flagx=1;
				if(pot[cnt].y>=m)
					flagy=1;
			}
		}
		int l=0,fi=0;
		if(flagx&&flagy&&cnt==1)
			printf("1\n%d %d\n",pot[0].x,pot[0].y);
		else if(flagx&&flagy)
		{
			sort(pot,pot+cnt,cmp);
			int ff=0;
			while(l<m)
			{
				for(i=fi;i<cnt;i++)
				{
					if(pot[i].x>l&&i>0&&pot[i-1].y<pot[i].x)
					{
						ff=1;
						printf("0\n");
						break;
					}
					else if(pot[i].x>l)
						break;
				}
				sort(pot+fi,pot+i,cmp1);
				num[++mcnt]=pot[i-1].x;
				num[++mcnt]=pot[i-1].y;
				l=pot[i-1].y;
				fi=i;
				if(ff)
					break;
			}
			if(ff)
			{
				puts("");
				continue;
			}
			printf("%d\n",mcnt/2);
			for(i=1;i<=mcnt;i+=2)
			{
				printf("%d %d\n",num[i],num[i+1]);
			}
		}
		else
		{
			printf("0\n");
		}
		if(t)
			puts("");
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值