【Watering Grass】【UVA - 10382】(区间覆盖)

题目:

    n sprinklers are installed in a horizontal strip of grass l meters long and w meters wide. Each sprinkler is installed at the horizontal center line of the strip. For each sprinkler we are given its position as the distance from the left end of the center line and its radius of operation.

What is the minimum number of sprinklers to turn on in order to water the entire strip of grass?

Input

Input consists of a number of cases. The first line for each case contains integer numbers n, l and w with n ≤ 10000. The next n lines contain two integers giving the position of a sprinkler and its radius of operation. (The picture above illustrates the first case from the sample input.)

Output

For each test case output the minimum number of sprinklers needed to water the entire strip of grass. If it is impossible to water the entire strip output ‘-1’.

Sample Input

8 20 2

5 3

4 1

1 2

7 2

10 2

13 3

16 2

19 4

3 10 1

3 5

9 3

6 1

3 10 1

5 3

1 1

9 1

Sample Output

6

2

-1

 

解题报告:区间覆盖的二维转换为一维,给定的l,w,然后将他们实例化一维的就可以了,需要注意一点就是转换的时候,如果散水车的半径小于草坪一半的宽度,就无用。转化的半径是sqrt(r*r-w*w).

ac代码:

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<iostream>
using namespace std;

const int maxn =1e5+1000;

struct node{
	double l,r;
	node(){}
	node(double ll,double rr)
	{
		l=ll;
		r=rr;
	}
}num[maxn];

bool cmp(node a,node b)
{
	return a.l<b.l;
}

int solve(int n,double m)
{
	sort(num,num+n,cmp);
	double r=0;
	int p=0,ans=0;
	while(r<m)
	{
		double rr=r;
		while(p<n&&num[p].l<=r)
		{
			if(num[p].r>rr)
				rr=num[p].r;
			p++;
		}
		if(rr==r)
			return -1;
		ans++;
		r=rr;
	}
	return ans;
}
int main()
{
	int n;
	double l,w;
	while(scanf("%d%lf%lf",&n,&l,&w)==3)
	{
		int nn=0;
		w/=2;
		for(int i=0;i<n;i++)
		{
			double p,r;
			scanf("%lf%lf",&p,&r);
			if(r<=w)
				continue;
			num[nn++]=node(p-sqrt((double)(r*r-w*w)),p+sqrt((double)(r*r-w*w)));
		}
		printf("%d\n",solve(nn,l));
	}
}
/*
8 20 2
5 3
4 1
1 2
7 2
10 2
13 3
16 2
19 4
3 10 1
3 5
9 3
6 1
3 10 1
5 3
1 1
9 1
*/

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值