1014 Waiting in Line (30分)

1014 Waiting in Line (30分)

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (N**M+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customeri will take T**i minutes to have his/her transaction processed.
  • The first N customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 customers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, custome**r1 is served at windo**w1 while custome**r2 is served at windo**w2. Custome**r3 will wait in front of windo**w1 and custome**r4 will wait in front of windo**w2. Custome**r5 will wait behind the yellow line.

At 08:01, custome**r1 is done and custome**r5 enters the line in front of windo**w1 since that line seems shorter now. Custome**r2 will leave at 08:02, custome**r4 at 08:06, custome**r3 at 08:07, and finally custome**r5 at 08:10.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (≤20, number of windows), M (≤10, the maximum capacity of each line inside the yellow line), K (≤1000, number of customers), and Q (≤1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output Specification:

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output Sorry instead.

Sample Input:

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

Sample Output:

08:07
08:06
08:10
17:00
Sorry

题目大意:

模拟银行排队,有n个窗口,每个窗口前可以排m个人,一共有k个客户,有q个客户想要查询自己的服务开始时间。银行从早上八点营业到下午五点,超过五点、还未开始服务的客户不能进行服务(输出Sorry)

思路:

本题需要较多的数组来存储数据,主要需要的数据如下:

  • 窗口排队区域什么时候空位置(poptime)
  • 窗口处理完当前所有排队的人需要到什么时候(endtime)
#include <iostream>
#include <queue>
#include <vector>
using namespace std;
struct node
{
    // poptime:窗口当前处理客户处理完成的时间
    // 当前所在窗口黄线内的客户全部处理完的时间
    int poptime, endtime;
    queue<int> q;
};
int main()
{
    int n, m, k, q, index = 1;
    scanf("%d %d %d %d", &n, &m, &k, &q);
    vector<int> time(k + 1), result(k + 1);
    vector<node> window(n + 1);
    vector<bool> sorry(k + 1, false);
    for (int i = 1; i <= k; i++)
    {
        scanf("%d", &time[i]);
    }
    //先把黄线内的客户全部排队排好
    for (int i = 1; i <= m; i++)
    {
        for (int j = 1; j <= n; j++)
        {
            if (index <= k)
            {
                window[j].q.push(time[index]);
                if (window[j].endtime >= 540)
                    sorry[index] = true;
                window[j].endtime += time[index];
                if (i == 1)
                    window[j].poptime = window[j].endtime;
                result[index] = window[j].endtime;
                index++;
            }
        }
    }
    // 模拟操作
    while (index <= k)
    {
        // 先找到第一个腾出空位置的窗口
        int tempmin = window[1].poptime, tempwindow = 1;
        for (int i = 2; i <= n; i++)
        {
            if (window[i].poptime < tempmin)
            {
                tempwindow = i;
                tempmin = window[i].poptime;
            }
        }
        // 下一个客户进入黄线等待
        window[tempwindow].q.pop();
        window[tempwindow].q.push(time[index]);
        window[tempwindow].poptime += window[tempwindow].q.front();
        if (window[tempwindow].endtime >= 540)
            sorry[index] = true;
        window[tempwindow].endtime += time[index];
        result[index] = window[tempwindow].endtime;
        index++;
    }
    // 输出
    for (int i = 1; i <= q; i++)
    {
        int query, minute;
        scanf("%d", &query);
        minute = result[query];
        if (sorry[query] == true)
        {
            printf("Sorry\n");
        }
        else
        {
            printf("%02d:%02d\n", (minute + 480) / 60, (minute + 480) % 60);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值