1002 A+B for Polynomials (25分)

题目:
This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ … N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

解题思路:
题目的要求是求两个多项式的和,刚开始我一看到多项式求和就立马想到用链表来解决,毕竟当时学数据结构时两个多项式求和就是用到的链表,然后就花了蛮长时间,但后面发现没必要,因为这道题用链表太麻烦了,还得构建链表以及考虑多种情况。
直接用一个数组来实现多项式求和,数组下标表示幂,值则代表系数,但也需要注意以下几点:
1、输出格式要保留小数点后一位
2、最后不能带空格
3、要考虑两个系数和为0的情况,为0则不输出

代码如下:

#include<stdio.h>
#include <iomanip>
#include<iostream>

using namespace std;

double a[1002];

int main() {
	int k1,k2, exp,count=0;
	double coe;
	cin >> k1;
	for (int i = 0; i < k1; i++) {
		cin >> exp >> coe;
		a[exp] = coe;
	}
	cin >> k2;
	count =k1 + k2;
	for (int i = 0; i < k2; i++) {
		cin >> exp >> coe;
		if (a[exp] != 0)//考虑相同幂的情况
			count--;
		if (a[exp] + coe == 0)//考虑两个系数和为0的情况,为0不输出
			count--;
		a[exp] += coe;
	}
	cout << count;
	for (int i = 1000; i >= 0; i--) {
		if(a[i]!=0)
			cout << " " << i << " " << setiosflags(ios::fixed) << setprecision(1) << a[i];
	}
		

	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值