PAT 1005 Spell It Right (20分)

题目:
Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (≤10​100​​).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

解题思路:
这道题相对简单,就是输入一个数字,然后计算这个数每位上的数字总和,然后将该总和上的每位数字转为对应的英文输出,即1+2+3+4+5=15,然后输出"one five"
可以直接将数字作为字符串输入,我刚开始是直接输入一个int类型然后转换为string时会失败,因为数字太大的话会超过字符串存储的内存。

代码如下:

#include<stdio.h>
#include<string>
#include<iostream>
using namespace std;
int N;
string s;
string Eng[10] = { "zero","one","two","three","four","five","six","seven","eight","nine" };
int main() {
	cin >> s;
	int sum = 0;
	int x;
	for (int i = 0; i < s.length(); i++) {
		x = s[i] - '0';//字符转换成对应的数字
		sum += x;
	}
	s = to_string(sum);
	for (int i = 0; i < s.length(); i++) {
		x = s[i] - '0';
		if (i == s.length() - 1)
			cout << Eng[x];
		else
			cout << Eng[x]<<" ";
	}

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值