PAT 1012 The Best Rank (25分)

题目:
To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

解题思路:
这道题就是输出所查询学生在这三个学科及平均成绩的最优排名。
可以用一个结构体保存每位学生的成绩信息以及他的每个学科和平均成绩所在的排名。
用sort来对A,C,M,E进行一次排序,需要注意的是相同的成绩排名相同,所以在保存排序信息的时候需要做一次判断。
查询学生成绩排名的时候可以用map来匹配是否存在该学生的成绩信息。

代码如下:

#include<stdio.h>
#include<algorithm>
#include<map>
#include<iostream>
using namespace std;

typedef struct students{
	string ID;
	int C, M, E;
	int RA, RC, RM, RE;
	double A;//平均数
};
struct students stu[2002], a[2002];
int N, M;
map<string, int> MAP;

int min(int a, int b) {
	return a < b ? a : b;
}

bool cmpA(students a, students b) {
	return a.A > b.A;
}
bool cmpC(students a, students b) {
	return a.C > b.C;
}
bool cmpM(students a, students b) {
	return a.M > b.M;
}
bool cmpE(students a, students b) {
	return a.E > b.E;
}

int main() {
	cin >> N >> M;
	for (int i = 0; i < N; i++) {
		cin >> stu[i].ID >> stu[i].C >> stu[i].M >> stu[i].E;
		stu[i].A = (stu[i].C + stu[i].M + stu[i].E) / 3;

	}
	sort(stu, stu + N, cmpA);
	for (int i = 0; i < N; i++) {
		if (i > 0 && stu[i].A == stu[i - 1].A) 
			stu[i].RA = stu[i - 1].RA;
		else
			stu[i].RA = i + 1;
	}
	sort(stu, stu + N, cmpC);
	for (int i = 0; i < N; i++) {
		if (i > 0 && stu[i].C == stu[i - 1].C)
			stu[i].RC = stu[i - 1].RC;
		else
			stu[i].RC = i + 1;
	}
	sort(stu, stu + N, cmpM);
	for (int i = 0; i < N; i++) {
		if (i > 0 && stu[i].M == stu[i - 1].M)
			stu[i].RM = stu[i - 1].RM;
		else
			stu[i].RM = i + 1;
	}
	sort(stu, stu + N, cmpE);
	for (int i = 0; i < N; i++) {
		if (i > 0 && stu[i].E == stu[i - 1].E)
			stu[i].RE = stu[i - 1].RE;
		else
			stu[i].RE = i + 1;
		MAP[stu[i].ID] = i+1;
	}
	
	for (int i = 0; i < M; i++) {
		cin >> a[i].ID;
	}
	for (int i = 0; i < M; i++) {
		int v = MAP[a[i].ID];
		if(v){
			int n = min(stu[v-1].RA, stu[v-1].RC) < min(stu[v-1].RM, stu[v-1].RE) ? min(stu[v-1].RA, stu[v-1].RC) : min(stu[v-1].RM, stu[v-1].RE);
			if (n == stu[v-1].RA) cout << n << " " << 'A' << endl;
			else if (n == stu[v-1].RC) cout << n << " " << 'C' << endl;
			else if (n == stu[v-1].RM) cout << n << " " << 'M' << endl;
			else cout << n << " " << 'E' << endl;
		}
		else
			cout << "N/A" << endl;
	}

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值