PAT 1021 Deepest Root (25分)

题目:
A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤10​4​​) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N−1 lines follow, each describes an edge by given the two adjacent nodes’ numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print Error: K components where K is the number of connected components in the graph.

Sample Input 1:

5
1 2
1 3
1 4
2 5

Sample Output 1:

3
4
5

Sample Input 2:

5
1 3
1 4
2 5
3 4

Sample Output 2:

Error: 2 components

解题思路:
首先先通过深度遍历来判断是否为一颗连通树,若是,再通过dfs遍历每一个结点,记录下它们的最大深度,然后比较输出即可。

参考一个博主的思路:https://www.cnblogs.com/zhanghaijie/p/10229733.html

代码如下:

#include<stdio.h>
#include<algorithm>
#include<vector>
#define MAX 10001
using namespace std;

bool visit[MAX];//记录是否被访问过的结点
vector<vector<int> > v;//构建邻接表
int N,deepest = 0;
int maxdeep = 0;//最大深度

void dfs(int root, int deep) {
	deepest = max(deepest, deep);
	for (int i = 0; i < v[root].size(); i++) {
		if (visit[v[root][i]] == false) {
			visit[v[root][i]] = true;
			dfs(v[root][i], deep+1);
		}
	}
}

int main() {
	int x, y, k = 0;
	scanf("%d", &N);
	v.resize(N + 1);
	for (int i = 0; i < N - 1; i++) {
		scanf("%d%d", &x, &y);
		v[x].push_back(y);
		v[y].push_back(x);
	}
	fill(visit, visit + N + 1, false);
	/*通过dfs遍历结点判断在graph中为一颗树还是多颗树*/
	for (int i = 1; i <= N; i++) {
		if (visit[i] == false) {
			k++;
			visit[i] = true;
			dfs(i, 0);
		}
	}
	if (k > 1)
		printf("Error: %d components", k);
	else {
		int maxi[MAX]; //存储每个root的最大深度
		for (int i = 1; i <= N; i++) {
			deepest = 0;
			fill(visit, visit + N + 1, false);
			visit[i] = true;
			dfs(i, 0);
			maxi[i] = deepest;
			maxdeep = max(maxdeep, deepest);
		}
		for (int i = 1; i <= N; i++) {
			if (maxi[i] == maxdeep)
				printf("%d\n", i);
		}
	}

	return 0;
	
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值