1025 PAT Ranking (25分)

题目:
Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

解题思路:
首先先对单个地方的考生进行排名,然后再对全部考生排名。
主要是记录我遇到的问题:
1、粗心没有考虑到在相同排名的情况下,registration number要升序排序,导致第一次提交时测试点2过不去。
2、测试点4一直过不去,想了很久都想不到问题出在哪,上网查了才发现输出registration number时没有考虑到前导0的问题。
在这里插入图片描述图片来自一个博主的文章:https://blog.csdn.net/qq_41173604/article/details/95521620

代码如下:

#include<stdio.h>
#include<string>
#include<algorithm>
#include<iostream>
using namespace std;

struct testees {
	long long regist_num;
	int score;
	int final_rank;
	int local_rank;
	int location;
};
struct testees testee[30001];
int cmp(testees a, testees b) {
	if (a.score == b.score)
		return a.regist_num < b.regist_num;
	return a.score > b.score;
}

int main() {
	int N, K,num = 0,last_num = 0;
	cin >> N;
	for (int i = 0; i < N; i++) {
		cin >> K;
		for (int j = 0; j < K; j++) {
			cin >> testee[num].regist_num >> testee[num].score;
			testee[num++].location = i + 1;
		}
		sort(testee + last_num, testee + num, cmp);//对单个地方的排名进行排序
		for (int k = last_num; k < num; k++) {
			if (k > last_num&& testee[k].score == testee[k - 1].score)//考虑成绩相等的情况
				testee[k].local_rank = testee[k - 1].local_rank;
			else {
				testee[k].local_rank = k - last_num + 1;
			}

		}
		last_num = num;
	}
	sort(testee, testee + num, cmp);//对全体考生的排序
	for (int i = 0; i < num; i++) {
		if (i > 0 && testee[i].score == testee[i - 1].score) 
			testee[i].final_rank = testee[i - 1].final_rank;
		else
			testee[i].final_rank = i + 1;
	}
	cout << num<<endl;
	for (int i = 0; i < num; i++)
		//cout << testee[i].regist_num << " " << testee[i].final_rank << " " << testee[i].location << " " << testee[i].local_rank<<endl;
		printf("%013lld %d %d %d\n", testee[i].regist_num, testee[i].final_rank, testee[i].location, testee[i].local_rank);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值