B - Blow up the Enemy

https://vjudge.net/contest/386568#problem/B

Zhang3 is playing a shooting game with Father. In the game there are two players trying to kill each other to win the game.

The game provides  nn weapons, each has two properties: Damage and Delay. The ithith weapon has Damage AiAi and Delay DiDi. When a player shoots with this weapon, his enemy's HP is reduced by AiAi, then he must wait for DiDi ms before he can shoot again.

The game processes as follows:

1. Before the game starts, Zhang3 and Father choose a weapon respectively. Father always randomly chooses one of the nn weapons with equal probabilities. Each player can only use the chosen weapon during the game.
2. When the game starts, Zhang3 and Father have 100100 HP each. They make their first shot at the same time.
3. They keep shooting as quickly as possible. That means, a player shoots instantly whenever he can shoot, until the game ends.
4. When a player's HP is reduced to 0 or lower, he dies and the game ends. If the other player is still alive (i.e. has HP higher than 0), then the living player wins the game; otherwise (if the two players die at the same time), each player has 50%50% probability to win the game.

Zhang3 wants to win the game. Please help her to choose a weapon so that the probability to win is maximized. Print the optimal probability.

InputThe first line of the input gives the number of test cases, T(1T100)T(1≤T≤100). TT test cases follow.

For each test case, the first line contains an integer n(1n1000)n(1≤n≤1000), the number of weapons in the game.

Then nn lines follow, the ithith of which contains two integers Ai,Di(1Ai100,1Di10000)Ai,Di(1≤Ai≤100,1≤Di≤10000), representing the Damage and the Delay of each weapon.

The sum of nn in all test cases doesn't exceed 20002000.
OutputFor each test case, print a line with a real number p(0p1)p(0≤p≤1), representing the optimal probability.

Your answers should have absolute or relative errors of at most 10610−6.
Sample Input

2
1
100 100
4
50 50
40 20
30 10
20 100

Sample Output

0.5
0.875

题意:

  父亲 和 儿子 对战游戏:

    从n个武器中选择一种,每种武器有伤害A,两次使用的时间间隔D

    父亲的武器随机选择,儿子选一种武器,使得儿子获胜概率最大。

    输出最大获胜率

思路:

  贪心,儿子选择性价比最高的,使得在时间相同的情况下打出的伤害更快达到100;

  父亲选择强道具的概率 = 强道具个数 / n;

  则儿子获胜概率为 (1/2)强道具个数 / n;

  1)父亲未选择强武器,概率(n - 强道具个数)/ 强道具个数;

  2)在此情况下儿子胜率为(n - 强道具个数)/ 强道具个数

  最大概率为两数和

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<bitset>
#include<cassert>
#include<cctype>
#include<cmath>
#include<cstdlib>
#include<ctime>
#include<deque>
#include<iomanip>
#include<list>
#include<map>
#include<queue>
#include<set>
#include<stack>
#include<vector>
#include <vector>
#include <iterator>
#include <utility>
#include <sstream>
#include <limits>
#include <numeric>
#include <functional>
using namespace std;
#define gc getchar()
#define mem(a) memset(a,0,sizeof(a))
//#define sort(a,n,int) sort(a,a+n,less<int>())

#define ios ios::sync_with_stdio(false);cin.tie(0);cout.tie(0);

typedef long long ll;
typedef unsigned long long ull;
typedef long double ld;
typedef pair<int,int> pii;
typedef char ch;
typedef double db;

const double PI=acos(-1.0);
const double eps=1e-6;
const int inf=0x3f3f3f3f;
const int maxn=1e5+10;
const int maxm=100+10;
const int N=2e5+10;
const int mod=1e9+7;


double P = 0;
double A = 0 , D = 0;
double Bestchoice = 0;
double T = 0;
double T_min = 1e9;
int main()
{
	int t = 0;
	int n = 0;
	cin >> t;
	while(t--)
	{
		Bestchoice = 0;
		T = 0;
		T_min = 1e9;
		cin >> n;
		for(int i = 0;i<n;i++)
		{
		 	cin >> A >> D;
		 	T = D * ((100+A-1)/A - 1);
		 	if(T == T_min)
			{
			 	Bestchoice += 1;
			} 
		 	if(T < T_min)
			{
		 	 	T_min = T;
		 		Bestchoice = 1;
			}
		}	
	    P = (n-Bestchoice)/n + Bestchoice/(n*2);
	    cout << setprecision(2) << P <<endl;
    }
	return 0;
}

 

 
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
对于计算机专业的学生而言,参加各类比赛能够带来多方面的益处,具体包括但不限于以下几点: 技能提升: 参与比赛促使学生深入学习和掌握计算机领域的专业知识与技能,如编程语言、算法设计、软件工程、网络安全等。 比赛通常涉及实际问题的解决,有助于将理论知识应用于实践中,增强问题解决能力。 实践经验: 大多数比赛都要求参赛者设计并实现解决方案,这提供了宝贵的动手操作机会,有助于积累项目经验。 实践经验对于计算机专业的学生尤为重要,因为雇主往往更青睐有实际项目背景的候选人。 团队合作: 许多比赛鼓励团队协作,这有助于培养学生的团队精神、沟通技巧和领导能力。 团队合作还能促进学生之间的知识共享和思维碰撞,有助于形成更全面的解决方案。 职业发展: 获奖经历可以显著增强简历的吸引力,为求职或继续深造提供有力支持。 某些比赛可能直接与企业合作,提供实习、工作机会或奖学金,为学生的职业生涯打开更多门路。 网络拓展: 比赛是结识同行业人才的好机会,可以帮助学生建立行业联系,这对于未来的职业发展非常重要。 奖金与荣誉: 许多比赛提供奖金或奖品,这不仅能给予学生经济上的奖励,还能增强其成就感和自信心。 荣誉证书或奖状可以证明学生的成就,对个人品牌建设有积极作用。 创新与研究: 参加比赛可以激发学生的创新思维,推动科研项目的开展,有时甚至能促成学术论文的发表。 个人成长: 在准备和参加比赛的过程中,学生将面临压力与挑战,这有助于培养良好的心理素质和抗压能力。 自我挑战和克服困难的经历对个人成长有着深远的影响。 综上所述,参加计算机领域的比赛对于学生来说是一个全面发展的平台,不仅可以提升专业技能,还能增强团队协作、沟通、解决问题的能力,并为未来的职业生涯奠定坚实的基础。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

YukiRinLL

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值