1034 求整数的位数
Time Limit : 2000/1000 MS(Java/Others) | Memory Limit :65536/32768 KB(Java/Others)
Submits : 10308 | Solved : 4400
Description
输入一个任意长度的整数N(N>=0),求出它是几位数。
Input
输入一个任意长度的整数N(N>=0,且在int类型范围内)。
Output
输出位数
Sample Input
780
Sample Output
3
HINT
Source
NBU OJ
#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
int main()
{
int x;
int ans=0;
cin >> x;
do
{
ans++;
}while (x /= 10);
cout<<ans<<endl;
return 0;
}