7-1 最长对称子串 (25 分)

96 篇文章 7 订阅
49 篇文章 1 订阅

对给定的字符串,本题要求你输出最长对称子串的长度。例如,给定Is PAT&TAP symmetric?,最长对称子串为s PAT&TAP s,于是你应该输出11。

输入格式:

输入在一行中给出长度不超过1000的非空字符串。

输出格式:

在一行中输出最长对称子串的长度。

输入样例:

Is PAT&TAP symmetric?

输出样例:

11
#include<bits/stdc++.h>
using namespace std;
int main()
{
    string s;
    getline(cin,s);
    int num=0;
    for(int i=0;i<=s.length()-1;i++){
        int k=i,f=1;
        int t=s.length()-1;
        while(s[k]!=s[t])t--;
        int tt=t;
        for(int j=k;j<=tt;j++){
            if(s[j]!=s[tt]){
                f=0;break;
            }
            tt--;
        }
        if(f==1&&t-k+1>num)num=t-k+1;
    }
    cout<<num<<endl;
}

代码二:

#include<bits/stdc++.h>
using namespace std;

int main()
{
    string s;
    getline(cin,s);
    int len=s.length();
    int cnt=0;
    for(int i=0;i<len;i++)
    {
        int r=i,t=i;
        int sum=0;
        if(s[i]==s[i+1]){
            t=i+1;
            while(s[--r]==s[++t]&&r>=0&&t<len){
                sum++;
            }
            if(sum*2+2>cnt)cnt=2*sum+2;
        }
        else {
            while(s[--r]==s[++t]&&r>=0&&t<len){
                sum++;
            }
            if(sum*2+1>cnt)cnt=2*sum+1;
        }

    }
    cout<<cnt<<endl;
}
  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值