[USACO07MAR] Monthly Expense S

[USACO07MAR] Monthly Expense S

原题链接:https://www.luogu.com.cn/problem/P2884?contestId=149617

题目描述

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called “fajomonths”. Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ’s goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

给出农夫在n天中每天的花费,要求把这n天分作m组,每组的天数必然是连续的,要求分得各组的花费之和应该尽可能地小,最后输出各组花费之和中的最大值

输入格式

Line 1: Two space-separated integers: N and M

Lines 2…N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

输出格式

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

样例 #1

样例输入 #1

7 5
100
400
300
100
500
101
400

样例输出 #1

500

提示

If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

解题思路如下

1.首先,需要读取输入数据。输入数据包括两部分:第一行是两个整数N和M,分别表示时间段的长度和月份数;接下来的N行是每天的开销。
2.按照月份将每天的开销进行分组。我们可以使用一个数组来保存每个月的开销总和。
3.使用循环遍历每天的开销,将其累加到对应月份的总开销中,可以使用一个变量来记录当前月份的索引。
4.当遍历完所有的开销后就可以得到每个月的总开销,将这些总开销输出即可。

代码如下

#include<iostream>
using namespace std;
int n,m;
int a[100007];
int l,r,mid;

int main(){
	cin >> n >> m;
	for(int i = 1;i <= n;i++){
		cin >> a[i];
		l = max(l,a[i]);//预处理,最小开销至少跟花费最大的那个月一样
		r += a[i];//最大开销可能是所有的月加起来
	}
	while(l < r){
		mid = (l + r) / 2;
		int sum = 0,cnt = 0;
        	//sum是累加当前的钱,cnt是要分成几组
		for(int i = 1;i <= n;i++){
			if(sum + a[i] <= mid)//如果加上这个月的花费还比枚举到的开销小
				sum += a[i];//继续加
			else sum = a[i],cnt++;//不然就要分一组出来
		}
		if(cnt >= m)l = mid + 1;//可以分的组数较多,说明开销还可以更大
		else r = mid;//开销太大导致分的组数少
	}
	cout << l << endl;//最后的l即为答案
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

GBK_UTF-8

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值