HDU 1241 石油储蓄 (简单DFS)

最近几天开始做简单的搜索题 做的杭电的 1010,2040,2041
这是2041的题目和代码,上课时候在纸上写了一遍,对这个模板不熟悉,还是参考了大神们的标准代码。

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either *', representing the absence of oil, or@’, representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
Sample Input

1 1
*
3 5
@@*
@
@@*
1 8
@@***@
5 5
****@
@@@
@**@
@@@
@
@@**@
0 0

Sample Output

0
1
2
2

题意
有n*m的表,*是空地,@代表有石油
互相连通的石油算一种,要求他有多少种石油;
连通的话,算上下左右,还有四个对角线。

先枚举map里每一个元素,如果是@,计数就加一,
调用dfs将与其相连通的全修改成*

#include<stdio.h> 
char map [101][101];
int mx[8]={0,0,1,-1,1,1,-1,-1};
int my[8]={1,-1,0,0,-1,1,1,-1};

void dfs(int x,int y)
{
	map[x][y]='*';//更改其标志,防止重复计算
	int dx,dy;
	for(int i=0;i<8;i++)
	{
		dx=x+mx[i];
		dy=y+my[i];
		if(map[dx][dy]=='@')
		{
			dfs(dx,dy);
		}
	}
}

int main()
{
	int n,m;
	while (scanf("%d %d",&n,&m)!=EOF)
	{    
	if(m==0||n==0)
	break;
	int sum=0;
		for(int i=0;i<n;i++)
		scanf("%s",map[i]);
		for(int i=0;i<n;i++)
		{
			for(int j=0;j<m;j++)
			{
				if(map[i][j]=='@')
				{
					dfs(i,j);
					sum++;
				}
			}
		}
		printf("%d\n",sum);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值