称硬币(枚举题)

称硬币

题目:

有12枚硬币。其中有11枚真币和1枚假币。假币和真币重量不同,但是不知道假币比真币轻还是重。现在,用一架天平称了这些币三次,告诉你称的结果,请你找出假币并且确定假币是轻还是重(数据保证一定可以找出)。

样例输入

1

ABCD EFGH even(平的)

ABCI EFJK up (右边轻)

ABIJ EFGH even (平的)

样例输出

K is the counterfeit coin and it is light

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;


char Left[3][7];//天平左边硬币
char Right[3][7];//天平右边的硬币
char result[3][7];//结果
bool IsFake(char c,bool light);//light 为真表示假设硬币为轻,否则为重。



int main(){
    int t;
    cin>>t;
    while (t--){
    
		for(int i=0;i<3;++i)cin>>Left[i]>>Right[i]>>result[i];
		
        for(char c='A';c<='L';c++){
        
			if(IsFake(c,true)){
				cout<<c<<"is the counterfeit coin and it is light.\n";
                break;
            }
            
            else if(IsFake(c,false)){
				cout<<c<<"is the counterfeit coin and it is heavy.\n";
              	break;
            }
        
        }
    
    }
    return 0;
    
}


bool IsFake(char c,bool light)
{
	for (int i=0;i<3;++i)
    {
        char* pLeft,*pRight;
        
        if(light){
			pLeft=Left[i];
            pRight=Right[i];
        }
        
        else {
			pLeft=Right[i];
            pRight=Left[i];
        }	
        
        switch(result[i][0]){
        
            case 'u':
                if(strchr(pRight,c)==NULL)
                    return false ;
                break;
                
            case 'e':
                if(strchr(pLeft,c)||strchr(pRight,c))
                    return false ;
                break;
                
            case 'd':
                if(strchr(pLeft,c)==NULL)
                    return false ;
                break;
        
        }
    }
    return true;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值