Nightmare(广搜

Nightmare

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13949    Accepted Submission(s): 6758


 

Problem Description

Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.

 

 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius' start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius' target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.

 

 

Output

For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.

 

 

Sample Input

 

3 3 3 2 1 1 1 1 0 1 1 3 4 8 2 1 1 0 1 1 1 0 1 0 4 1 1 0 4 1 1 0 0 0 0 0 0 1 1 1 1 4 1 1 1 3 5 8 1 2 1 1 1 1 1 4 1 0 0 0 1 0 0 1 1 4 1 0 1 1 0 1 1 0 0 0 0 3 0 1 1 1 4 1 1 1 1 1

 

 

Sample Output

 

4 -1 13

这题不是太难,但总是输出不对,看了两个小时,最后才发现只是一个字母错了。最后改过来居然还是编译错误,暂且存这里以后再做一遍吧。(错误已订正,next数组名称不能为next)

AC代码:

#include<iostream>  
#include<cstdio>  
#include<queue>  
#include<cstring>  
using namespace std;
const int N = 8;  
const int M = 8;  
int  mp[N+2][M+2];  
int n,m;  
int br[N+2][M+2];  
struct Node  
{  
    int x,y;  
    int t;//剩下的时间   
    int step;// 走了的步数   
};  
int dx[4] = {0,0,1,-1};  
int dy[4] = {1,-1,0,0};  
int bfs(int sx,int sy)  
{  
    memset(br,0,sizeof br);  
    Node h;  
    h.x = sx,h.y = sy,h.t = 6,h.step = 0;  
    br[h.x][h.y] = 6;  
    queue<Node>q;  
    while (!q.empty()) q.pop();  
    q.push(h);  
    while (!q.empty())  
    {  
        h = q.front();  
        q.pop();  
        for (int i = 0;i < 4;++i)  
        {  
            Node nx;  
            nx.t = h.t - 1;  
            nx.x = h.x + dx[i];  
            nx.y = h.y + dy[i];  
            nx.step = h.step + 1;  
            if (nx.x>=1&&nx.y>=1&&nx.x<=n&&nx.y<=m)  
            {  
                  
                if (mp[nx.x][nx.y] == 4)  
                {  
                    if (6 > br[nx.x][nx.y])  
                    {  
                        nx.t = 6;  
                        q.push(nx);   
                        br[nx.x][nx.y] = 6;  
                    }  
                }  
                else if (mp[nx.x][nx.y] == 1)  
                {  
                    if (nx.t == 1) continue;// =-= 没机会了  下一步走到哪都是死  
                    if (br[nx.x][nx.y] < nx.t)  
                    {  
                        q.push(nx);  
                        br[nx.x][nx.y] = nx.t;  
                    }  
                }  
                else if (mp[nx.x][nx.y] == 3)  
                {  
                    return nx.step;  
                }  
            }  
        }  
    }  
    return -1;  
}  
int main()  
{  
    int T;  
    scanf("%d",&T);  
    while (T--)  
    {  
        int sx,sy;  
        scanf("%d%d",&n,&m);  
        for (int i = 1;i <= n;++i)  
        {  
            for (int j = 1;j <= m;++j)  
            {  
                scanf("%d",&mp[i][j]);  
                if (mp[i][j] == 2)  
                {  
                    sx = i,sy = j;  
                }  
            }  
        }  
        cout<<bfs(sx,sy)<<endl;  
    }  
    return 0;  
} 

 未ACdada代码(先存着,有空再找bug):

#include<cstdio>
#include<queue>
#include<cstring>
using namespace std;
int n,m;
int d[10][10];
int map[10][10];
int nextb[4][2]={0,-1,0,1,-1,0,1,0};

struct node
{
	int x,y,step,t;
};

int bfs(int sx,int sy)
{
	queue<node>q;
	memset(d,0,sizeof(d));
	while(!q.empty())
	q.pop();
	node h;
	h.x=sx;h.y=sy;h.step=0;h.t=6;d[h.x][h.y]=6;
	q.push(h);
	while(!q.empty())
	{
		h=q.front();q.pop();
		for(int i=0;i<4;i++)
		{
			node v;
			v.x=h.x+nextb[i][0];
			v.y=h.y+nextb[i][1];
			v.step=h.step+1;
			v.t=h.t-1;
			if(v.x>=1&&v.x<=n&&v.y>=1&&v.y<=m)
			{
				if(map[v.x][v.y]==4)
				{
					if(d[v.x][v.y]<6)
					{
						v.t=6;
					q.push(v);
					d[v.x][v.y]=6;
					}
					
				}
			
				else if(map[v.x][v.y]==1)
				{
					if(v.t==1)
					continue;
					if(d[v.x][v.y]<v.t)
					{
					    q.push(v);
						d[v.x][v.y]=v.t;
						
					}
				}
					else if(map[v.x][v.y]==3)
				{
					return v.step;
				}
			}
		}
		
	}
	
	return -1;
}

int main()
{
	int t,sx,sy;
    scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		for(int i=1;i<=n;i++)
		for(int j=1;j<=m;j++)
		{
			scanf("%d",&map[i][j]);
			if(map[i][j]==2)
			{
				sx=i;sy=j;
			}
		}
		printf("%d\n",bfs(sx,sy));
		
	}
	
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值