Nightmare(BFS)

Problem Description
Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius’ start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:

  1. We can assume the labyrinth is a 2 array.
  2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
  3. If Ignatius get to the exit when the exploding time turns to 0, he can’t get out of the labyrinth.
  4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can’t use the equipment to reset the bomb.
  5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
  6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.
    Input
    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
    There are five integers which indicate the different type of area in the labyrinth:
    0: The area is a wall, Ignatius should not walk on it.
    1: The area contains nothing, Ignatius can walk on it.
    2: Ignatius’ start position, Ignatius starts his escape from this position.
    3: The exit of the labyrinth, Ignatius’ target position.
    4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.
    Output
    For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.
    Sample Input
    3
    3 3
    2 1 1
    1 1 0
    1 1 3
    4 8
    2 1 1 0 1 1 1 0
    1 0 4 1 1 0 4 1
    1 0 0 0 0 0 0 1
    1 1 1 4 1 1 1 3
    5 8
    1 2 1 1 1 1 1 4
    1 0 0 0 1 0 0 1
    1 4 1 0 1 1 0 1
    1 0 0 0 0 3 0 1
    1 1 4 1 1 1 1 1
    Sample Output
    4
    -1
    13
    题目大意:从2走到3,初始时间限定为6秒,每走一步用一秒,遇到4且剩下的时间大于0才可以重置为6,0为墙。
    直接bfs,但是在这里可以不用再设vis数组来标记走过的点,因为有时间来限定,但是如果不停的走到4,也会出现死循环,时间无限重置为6了,所以在经过了4以后,把4设为1,这样就不会出现死循环,也可以回头走。具体可以根据案例三推演一遍。
#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<queue>
using namespace std;

int T,n,m;
int mov[4][2] = {{1,0},{-1,0},{0,1},{0,-1}};
int mapp[10][10];
//int vis[10][10];
int stx,sty,edx,edy;

struct node
{
    int x,y,step,time;
};

int bfs()
{
    node a,next;
    queue<node> q;
    a.x = stx;
    a.y = sty;
    a.step = 0;
    a.time = 6;
    //vis[a.x][a.y] = 1;
    q.push(a);
    while(!q.empty())
    {
        a = q.front();
        q.pop();
        if(a.x == edx && a.y == edy && a.time>0)
            return a.step;
        for(int i = 0; i<4; i++)
        {
            int xx = a.x+mov[i][0];
            int yy = a.y+mov[i][1];
            if(xx<0 || xx>=n || yy<0 || yy>=m || a.time == 1)
            {
                continue;
            }
            if(mapp[xx][yy]!=0 )// !vis[xx][yy] && a.time>0
            {
                next.x = xx;
                next.y = yy;
                next.step = a.step+1;
                if(mapp[xx][yy] == 4 && next.time>0)
                    next.time = 6;
                else
                    next.time = a.time-1;
                q.push(next);
                mapp[xx][yy] = 1;//因为有时间来限制,所以可以不用vis来标记,以便可以重置时间后往回走,
                //但是为了防止死循环,可以把重置的点设为1,这样时间走完了就没了,不会出现死循环
            }
        }
    }
    return -1;
}

int main()
{
    while(~scanf("%d",&T))
    {
        while(T--)
        {
            scanf("%d%d",&n,&m);
            for(int i = 0; i<n; i++)
            {
                for(int j = 0; j<m; j++)
                {
                    scanf("%d",&mapp[i][j]);
                    if(mapp[i][j] == 2)
                    {
                        stx = i;
                        sty = j;
                    }
                    if(mapp[i][j] == 3)
                    {
                        edx = i;
                        edy = j;
                    }
                }
            }
            //memset(vis,0,sizeof(vis));
            printf("%d\n",bfs());
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值