Remainder(广搜

Remainder

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4666    Accepted Submission(s): 1176


 

Problem Description

Coco is a clever boy, who is good at mathematics. However, he is puzzled by a difficult mathematics problem. The problem is: Given three integers N, K and M, N may adds (‘+’) M, subtract (‘-‘) M, multiples (‘*’) M or modulus (‘%’) M (The definition of ‘%’ is given below), and the result will be restored in N. Continue the process above, can you make a situation that “[(the initial value of N) + 1] % K” is equal to “(the current value of N) % K”? If you can, find the minimum steps and what you should do in each step. Please help poor Coco to solve this problem. 

You should know that if a = b * q + r (q > 0 and 0 <= r < q), then we have a % q = r.

 

 

Input

There are multiple cases. Each case contains three integers N, K and M (-1000 <= N <= 1000, 1 < K <= 1000, 0 < M <= 1000) in a single line.

The input is terminated with three 0s. This test case is not to be processed.

 

 

Output

For each case, if there is no solution, just print 0. Otherwise, on the first line of the output print the minimum number of steps to make “[(the initial value of N) + 1] % K” is equal to “(the final value of N) % K”. The second line print the operations to do in each step, which consist of ‘+’, ‘-‘, ‘*’ and ‘%’. If there are more than one solution, print the minimum one. (Here we define ‘+’ < ‘-‘ < ‘*’ < ‘%’. And if A = a1a2...ak and B = b1b2...bk are both solutions, we say A < B, if and only if there exists a P such that for i = 1, ..., P-1, ai = bi, and for i = P, ai < bi)

 

 

Sample Input

 

2 2 2 -1 12 10 0 0 0

 

 

Sample Output

 

0 2 *+

又是一道不认真,结果看了一个小时的题。

AC代码:

#include<cstdio>
#include<cstring>
#include<string>
#include<queue>
using namespace std;

int vis[1000000];
int n,k,m;
struct node
{
	string c;
	int step,yu;
};

void bfs()
{
	int km=k*m;int mod=((n+1)%k+k)%k;
	queue <node> q;
	node p,z;
	memset(vis,0,sizeof(vis));
	vis[(n%k+k)%k]=1;
	for(int i=0;i<4;i++)
	{
		p.c="";
		if(i==0)
		{
			p.yu=(n+m)%km;p.c+='+';p.step=1;
		}
		if(i==1)
		{
			p.yu=(n-m)%km;p.c+='-';p.step=1;
		}
		if(i==2)
		{
			p.yu=(n*m)%km;p.c+='*';p.step=1;
		}
		if(i==3)
		{
			p.yu=((n%m+m)%m)%km;p.c+='%';p.step=1;
		}
		if(vis[(p.yu%k+k)%k]==0) q.push(p);
		vis[(p.yu%k+k)%k]=1;
	}
	while(!q.empty())
	{
		p=q.front();q.pop();
		if(mod==(p.yu%k+k)%k)
		{
			printf("%d\n",p.step);
			for(int i=0;i<p.step;i++)
			printf("%c",p.c[i]);
			printf("\n");
			return;
		}
		for(int i=0;i<4;i++)
		{
			z.c=p.c;
			if(i==0)
		{
			z.yu=(p.yu+m)%km;z.c+='+';z.step=p.step+1;
		}
		    if(i==1)
		{
			z.yu=(p.yu-m)%km;z.c+='-';z.step=p.step+1;
		}
		    if(i==2)
		{
			z.yu=(p.yu*m)%km;z.c+='*';z.step=p.step+ 1;
		}
		    if(i==3)
		{
			z.yu=((p.yu%m+m)%m)%km;z.c+='%';z.step=p.step+ 1;
		}
		if(vis[(z.yu%k+k)%k]==0)
		q.push(z);
		vis[(z.yu%k+k)%k]=1;
		}
	}
	printf("0\n");
}

int main()
{
    
	while(~scanf("%d%d%d",&n,&k,&m)&&n&&k&&m)
	{
		bfs();
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值