Rescue

Rescue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 37605    Accepted Submission(s): 13027


 

Problem Description

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

 

 

Input

First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend. 

Process to the end of the file.

 

 

Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life." 

 

 

Sample Input

 

7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........

 

 

Sample Output

 

13

 

 又是编译错误。

别人AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include<queue>
using namespace std;
struct node{
    int x,y,t;
    friend bool operator<(node n1,node n2){
        return n2.t<n1.t;
    }
};
int n,m;
char map[210][210];
int d[210][210];
int ax,ay,rx,ry;
node ft;
int mx[]={1,0,-1,0};
int my[]={0,-1,0,1};

int judge(int x,int y){
    if(x<0||x>=n||y<0||y>=m){
        return 0;
    }
    if(map[x][y]=='#'){
        return 0;
    }
    if(d[x][y]){
        return 0;
    }
    return 1;
}

void bfs(){
    priority_queue<node> q;
    ft.x=rx;
    ft.y=ry;
    ft.t=0;
    q.push(ft);
    d[rx][ry]=1;
    while(!q.empty()){
        ft=q.top();
        q.pop();
        //printf("%d,%d,%d\n",ft.x,ft.y,ft.t);
        int x=ft.x;
        int y=ft.y;
        if(x==ax&&y==ay){
            printf("%d\n",ft.t);
            return;
        }
        for(int i=0;i<4;i++){
            x=ft.x+mx[i];
            y=ft.y+my[i];
            if(!judge(x,y)){
                continue;
            }
            node nt;
            if(map[x][y]=='.'||map[x][y]=='a'){
                nt.x=x;
                nt.y=y;
                nt.t=ft.t+1;
                d[x][y]=1;
                q.push(nt);
            }else if(map[x][y]=='x'){
                nt.x=x;
                nt.y=y;
                nt.t=ft.t+2;
                d[x][y]=1;
                q.push(nt);
            }
        }
    }
    printf("Poor ANGEL has to stay in the prison all his life.\n");
}


int main()
{
    while(~scanf("%d%d",&n,&m)){
        memset(d,0,sizeof(d));
        for(int i=0;i<n;i++){
            scanf("%s",map[i]);
            for(int j=0;j<m;j++){
                if(map[i][j]=='a'){
                    ax=i,ay=j;
                }
                if(map[i][j]=='r'){
                    rx=i,ry=j;
                }
            }
        }
        bfs();
    }
    return 0;
}

 我的错误代码:

#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
int n,m,sx,sy,ex,ey;
char map[201][201];
int vis[201][201];
int next[4][2]={0,1,0,-1,1,0,-1,0};

struct node
{
	int x,y,step;
	friend bool operator < (node a1,node a2)
	{
		return a1.step>a2.step;
	}
	
}b,c;

void bfs()
{
	b.x=sx;b.y=sy;b.step=0;
	priority_queue<node>q;
	q.push(b);
	vis[sx][sy]=1;
	while(!q.empty())
	{
		b=q.top();q.pop();
		if(b.x==ex&&b.y==ey)
		{
			printf("%d\n",b.step);return;
		}
		for(int i=0;i<4;i++)
		{
			c=b;
			c.x+=next[i][0];c.y+=next[i][1];
			if(c.x<0||c.y<0||c.x>=n||c.y>=m||vis[c.x][c.y]||map[c.x][c.y]=='#') continue;
			
			
				if(map[c.x][c.y]=='x')
				{
					vis[c.x][c.y]=1;
					c.step=b.step+2;
					q.push(c);
				}
				else
				{
					vis[c.x][c.y]=1;
					c.step=b.step+1;
					q.push(c);
				}
			
		}
	}
	printf("Poor ANGEL has to stay in the prison all his life.\n");return;
}

int main()
{
	while(~scanf("%d%d",&n,&m))
	{
	memset(vis,0,sizeof(vis));
		for(int i=0;i<n;i++)
	scanf("%s",map[i]);
	for(int i=0;i<n;i++)
	for(int j=0;j<m;j++)
	{
		if(map[i][j]=='r')
		sx=i,sy=j;
		else if(map[i][j]=='a')
		ex=i,ey=j;
	}
	
	bfs();
	}
	
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值