fabric系列一:适用于ubuntu18的Hyperledger-fabric2020年最新版2.3.0环境搭建

Hyperledger-fabric2.3.0环境搭建

准备工作

ubuntu18.0.3安装教程


1. 安装docker

1.1 首先,更新需求项

sudo apt update
sudo apt-get update

1.2 添加更新源

sudo apt-get install \ apt-transport-https \ ca-certificates \ curl \ gnupg-agent \ software-properties-common

1.3 添加docker下载镜像

curl -fsSL https://download.docker.com/linux/ubuntu/gpg | sudo apt-key add -

1.4 加入密钥与相关设置

sudo apt-key fingerprint 0EBFCD88

sudo add-apt-repository \ "deb [arch=amd64] https://download.docker.com/linux/ubuntu \ $(lsb_release -cs) \ stable"

1.5 安装docker

最后的准备(可有可无吧,这一步不需要成功,应该是只需要其中的一些启动项)

sudo apt-get update

sudo apt-get install docker-ce docker-ce-cli containerd.io

sudo apt-get update

之后重复运行上一步(这一步可以不全完成)

sudo apt-get install docker-ce=<5:18.09.9~3-0~ubuntu-bionic> docker-ce-cli=<5:18.09.9~3-0~ubuntu-bionic> containerd.io

实施安装

sudo apt-get install docker-ce -y

查看版本

docker version

1.6 加入用户

将用户加入该group内,然后退出并重新登陆

sudo gpasswd -a ${USER} docker

重启docker服务

systemctl restart docker

当前用户切换到docker数组

newgrp - docker

docker version


2. 安装docker-compose

2.1 安装依赖工具

sudo apt-get install python-pip -y

sudo pip install docker-compose

这一步成功了最好,不行了下一步
2.1 补充

python --version

如果python版本是2.7,进行如下操作,否则跳过
[升级python为3]

sudo apt-get install -y python3
cd /usr/bin/
sudo rm python
sudo ln -s /usr/bin/python3.6 /usr/bin/python
python -V

2.2 准备

cd ~
sudo apt-get install -y python3-pip 多刷新几次
pip -V

结果如下:

pip 9.0.1 from /usr/lib/python3/dist-packages (python 3.6)

2.3 安装docker-compose

sudo pip install docker-compose(可能会超时,解决办法如下)

选择镜像:(由于代码中包含`字符,以如下形式展示)

sudo curl -L https://get.daocloud.io/docker/compose/releases/download/1.25.1/docker-compose-`uname -s`-`uname -m` -o /usr/local/bin/docker-compose

2.4 加权限和查看版本

sudo chmod +x /usr/local/bin/docker-compose
docker-compose --version
docker-compose -h


3. 安装go

安装包下载地址:

  https://golang.org/dl/
  https://studygolang.com/dl

不用安装包:

3.1 用wget工具下载安装包

wget https://dl.google.com/go/go1.11.linux-amd64.tar.gz

若SSL无连接:

安装yum: sudo apt install yum
安装libssl-dev:sudo apt-get install libssl-dev
安装openssl:sudo apt-get install openssl
更新wget:sudo yum update wget

。。。。若仍然失败:在window下完传过来。。。。

3.2 解压tar包到/usr/local

sudo tar zxvf go1.15.6.linux-amd64.tar.gz -C /usr/local

3.3 创建Go目录

mkdir $HOME/go

3.4 用vi打开~./bashrc(下列二选一)

vim ~/.bashrc
vim ~/.bash_profile

3.5 增加环境变量

export GOROOT=/usr/local/go
export GOPATH=$HOME/go
export PATH=$PATH:$GOROOT/bin:$GOPATH/bin

3.6 使环境变量生效(对应3.4)

source ~/.bashrc
source ~/.bash_profile

3.7 检测go是否安装好

go version


4 安装Node.js

4.1 下载

官方地址:https://nodejs.org/en/download/

4.2 下载二进制源码包

wget https://nodejs.org/dist/v14.15.1/node-v14.15.1-linux-x64.tar.xz

4.3 解压并安装

指定压缩包解压到/opt目录下

sudo tar xvf node-v14.15.1-linux-x64.tar.xz -C /opt

4.4 将node.js设置为全局可用

打开系统级别的配置文件 /etc/profile

sudo vim /etc/profile

添加如下配置项,保存退出

export NODEJS_HOME=/opt/node-v14.15.1-linux-x64
export PATH=$PATH:$NODEJS_HOME/bin

重新加载配置文件

. /etc/profile

4.5 测试

node -v


5 部署hyperledger Fabric

5.1 创建放置的目录,然后进入目录用curl下载脚本

cd ~
mkdir hyperledger-fabric
cd hyperledger-fabric

5.1 下载执行脚本(可能很慢,可以参见5.2)

SELECT1 :

curl -sSL https://raw.githubusercontent.com/hyperledger/fabric/master/scripts/bootstrap.sh | bash -s 2.3.0 1.4.9 0.4.18

SELECT2 :

curl -sSL http://bit.ly/2ysb0FE | bash -s 2.3.0 1.4.9 0.4.18

相应做法:

1、二进制文件下载太慢,先把安装脚本保存下来

curl -sSL https://raw.githubusercontent.com/hyperledger/fabric/master/scripts/bootstrap.sh -o bootstrap.sh

2、到相应的网址下载二进制文件到fabric-samples文件夹(windows中下载再传进来)

https://github.com/hyperledger/fabric/releases/download/v2.3.0/hyperledger-fabric-linux-amd64-2.3.0.tar.gz

https://github.com/hyperledger/fabric-ca/releases/download/v1.4.9/hyperledger-fabric-ca-linux-amd64-1.4.9.tar.gz

3、解压

tar -zxvf hyperledger-fabric-linux-amd64-2.3.0.tar.gz
tar -zxvf hyperledger-fabric-ca-linux-amd64-1.4.9.tar.gz

4、打开bootstrap.sh在末尾注释脚本中pullBinaries语句,然后执行bootstrap.sh

sudo sh bootstrap.sh

5.2 另一种方式

1、直接git文件夹“fabric-samples”

git clone https://github.com/hyperledger/fabric-samples.git

2、到相应的网址下载二进制文件并放入fabric-samples文件夹(windows中下载再传进来)

https://github.com/hyperledger/fabric/releases/download/v2.3.0/hyperledger-fabric-linux-amd64-2.3.0.tar.gz

https://github.com/hyperledger/fabric-ca/releases/download/v1.4.9/hyperledger-fabric-ca-linux-amd64-1.4.9.tar.gz

3、解压

tar -zxvf hyperledger-fabric-linux-amd64-2.3.0.tar.gz
tar -zxvf hyperledger-fabric-ca-linux-amd64-1.4.9.tar.gz

4、打开bootstrap.sh在末尾注释脚本中pullBinaries语句,然后执行bootstrap.sh

sudo sh bootstrap.sh

5、将用户加入该group内,然后退出并重新登陆

sudo gpasswd -a ${USER} docker

重启docker服务

systemctl restart docker

当前用户切换到docker数组

newgrp - docker
docker version

6、进入到/fabric-samples/test-network 执行./network.sh进行实验

./network.sh up


至此,hyperledger-fabric2.3.0 已完全实现,作者从不同地方试用各类教程总结出的一套适用于2020年最新版2.3.0的fabric环境搭建,希望有所帮助!************************************************

  • 9
    点赞
  • 34
    收藏
    觉得还不错? 一键收藏
  • 11
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 11
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值