*题目
Problem Description
Boudreaux and Thibodeaux are on the road again . . .
"Boudreaux, we have to get this shipment of mudbugs to Baton Rouge by tonight!"
"Don't worry, Thibodeaux, I already checked ahead. There are three underpasses and our 18-wheeler will fit through all of them, so just keep that motor running!"
"We're not going to make it, I say!"
So, which is it: will there be a very messy accident on Interstate 10, or is Thibodeaux just letting the sound of his own wheels drive him crazy?
Input
Input to this problem will consist of a single data set. The data set will be formatted according to the following description.
The data set will consist of a single line containing 3 numbers, separated by single spaces. Each number represents the height of a single underpass in inches. Each number will be between 0 and 300 inclusive.
会输入三个数字,分别代表了三个隧道(underpass)的高度,范围是0-300
Output
There will be exactly one line of output. This line will be:
NO CRASH
if the height of the 18-wheeler is less than the height of each of the underpasses, or:
CRASH X
otherwise, where X is the height of the first underpass in the data set that the 18-wheeler is unable to go under (which means its height is less than or equal to the height of the 18-wheeler).
The height of the 18-wheeler is 168 inches.
如果货车的高度比三个隧道高度都小,输出“No CRASH”
(注意,这里不是小于等于)
如果不是,会输出”第一个“不能通过的隧道高度,不是最矮的隧道,而是第一个,也就是第一个遇到的,这个需要注意一些
Sample Input
180 160 170
Sample Output
CRASH 160
题目不难,主要是看懂题目
#include <iostream>
using namespace std;
int main()
{
int a,b,c;
while(cin>>a>>b>>c)
{
if(a>168&&b>168&&c>168)
{
cout<<"NO CRASH"<<endl;
}
else
{
if(a<=168)
{
cout<<"CRASH "<<a<<endl;
}
else if(b<=168)
{
cout<<"CRASH "<<b<<endl;
}
else if(c<168)
{
cout<<"CRASH "<<c<<endl;
}
}
}
}