tarjan算法求强连通分量

Network of Schools
A number of schools are connected to a computer network. Agreements have been developed among those schools: each school maintains a list of schools to which it distributes software (the “receiving schools”). Note that if B is in the distribution list of school A, then A does not necessarily appear in the list of school B
You are to write a program that computes the minimal number of schools that must receive a copy of the new software in order for the software to reach all schools in the network according to the agreement (Subtask A). As a further task, we want to ensure that by sending the copy of new software to an arbitrary school, this software will reach all schools in the network. To achieve this goal we may have to extend the lists of receivers by new members. Compute the minimal number of extensions that have to be made so that whatever school we send the new software to, it will reach all other schools (Subtask B). One extension means introducing one new member into the list of receivers of one school.

Input

The first line contains an integer N: the number of schools in the network (2 <= N <= 100). The schools are identified by the first N positive integers. Each of the next N lines describes a list of receivers. The line i+1 contains the identifiers of the receivers of school i. Each list ends with a 0. An empty list contains a 0 alone in the line.

Output

Your program should write two lines to the standard output. The first line should contain one positive integer: the solution of subtask A. The second line should contain the solution of subtask B.

Sample Input

5
2 4 3 0
4 5 0
0
0
1 0
Sample Output

1
2
题意:一共有n所学校之间可以传输文件,但是文件传输线路是单向传输,文件可以传递传输,求最少需要发送几份文件能使得

所有学校接收到文件,如果发送一份文件,就可以将文件传递给所有学校,最少需要添加几条单向传输网线

思路:强连通块内的点任意两点可以相互到达,缩为一点,入度为0的点必须手动传输文件,通过与其他点相连,消除将入度为0和出度为0 的点,整个图连成一块,向任意一点传输文件都可以使得所有学校得到文件

#include<iostream>
#include<cstring>
#include<cstdio>
#include<stack>
#include<vector>
using namespace std;
const int maxn=105;
int low[maxn],dfn[maxn];
int id,index,vis[maxn];
int include[maxn],in[maxn],out[maxn];
vector<int> G[maxn];
stack<int> p;
int n;
void tarjan(int u)
{
    low[u]=dfn[u]=++index;
    vis[u]=1;
    p.push(u);
    for(int i=0;i<G[u].size();i++)
    {
        int v=G[u][i];
        if(!dfn[v])
        {
            tarjan(v);
            low[u]=min(low[v],low[u]);
        }
        else if(vis[v]) low[u]=min(low[u],dfn[v]);
    }
    if(dfn[u]==low[u])
    {
        int v=u;
        include[v]=++id;
        do
        {
            v=p.top();
            p.pop();
            vis[v]=0;
            include[v]=id;
        }while(u!=v);
    }
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        id=index=0;
        memset(low,0,sizeof(low));
        memset(dfn,0,sizeof(dfn));
        memset(vis,0,sizeof(vis));
        memset(in,0,sizeof(in));
        memset(out,0,sizeof(out));
        for(int i=0;i<=n;i++)
            G[i].clear();
        for(int i=1;i<=n;i++)
        {
            int x;
            while(scanf("%d",&x)&&x)
            {
                G[i].push_back(x);
            }
        }
        for(int i=1;i<=n;i++)
        {
            if(!dfn[i]) tarjan(i);
        }
        for(int u=1;u<=n;u++)
        {
            for(int i=0;i<G[u].size();i++)
            {
                int v=G[u][i];
                if(include[v]!=include[u])
                {
                    in[include[v]]++;
                    out[include[u]]++;
                }
            }
        }
        int ans1=0,ans2=0;
        for(int i=1;i<=id;i++)
        {
            if(in[i]==0) ans1++;
            if(out[i]==0) ans2++;
        }
        if(id==1) cout<<1<<endl<<0<<endl;
        else cout<<ans1<<endl<<max(ans1,ans2)<<endl;
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值