JAVA判断合法标识符

JAVA判断合法标识符
Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description
输入若干行字符串,判断每行字符串是否可以作为JAVA语法的合法标识符。 判断合法标识符的规则:由字母、数字、下划线“_”、美元符号“$”组成,并且首字母不能是数字。

Input
输入有多行,每行一个字符串,字符串长度不超过10个字符,以EOF作为结束。

Output
若该行字符串可以作为JAVA标识符,则输出“true”;否则,输出“false”。

Sample Input
abc
_test
$test
a 1
a+b+c
a’b
123
变量

Sample Output
true
true
true
false
false
false
false
true

AC代码:

import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		Scanner mi = new Scanner(System.in);
		while (mi.hasNext()) {
			String str = mi.nextLine();
			char ch = str.charAt(0);
			int f = 1;
			if (Character.isJavaIdentifierStart(ch)) {
				for (int i = 1; i < str.length(); i++) {
					if (!Character.isJavaIdentifierPart(str.charAt(i))) {
						f = 0;
						break;
					}
				}
			} else {
				f = 0;
			}
			if (f == 1) {
				System.out.println("true");
			} else {
				System.out.println("false");
			}
		}
		mi.close();
	}
}

——————
余生还请多多指教!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值