计算长方形的周长和面积(类和对象)

Problem Description
设计一个长方形类Rect,计算长方形的周长与面积。
成员变量:整型、私有的数据成员length(长)、width(宽);
构造方法如下:
(1)Rect(int length) —— 1个整数表示正方形的边长
(2)Rect(int length, int width)——2个整数分别表示长方形长和宽
成员方法:包含求面积和周长。(可适当添加其他方法)
要求:编写主函数,对Rect类进行测试,输出每个长方形的长、宽、周长和面积。

Input
输入多组数据;
一行中若有1个整数,表示正方形的边长;
一行中若有2个整数(中间用空格间隔),表示长方形的长度、宽度。
若输入数据中有负数,则不表示任何图形,长、宽均为0。

Output
每行测试数据对应一行输出,格式为:(数据之间有1个空格)
长度 宽度 周长 面积

Sample Input
1
2 3
4 5
2
-2
-2 -3

Sample Output
1 1 4 1
2 3 10 6
4 5 18 20
2 2 8 4
0 0 0 0
0 0 0 0

AC代码:

import java.util.Scanner;

class Rect {
	int l, w;

	public void Rect1(int l) {
		if (l <= 0) {
			l = 0;
			w = 0;
		} else {
			this.l = l;
			w = l;
		}
	}

	public void Rect1(int l, int w) {
		if (l <= 0 || w <= 0) {
			this.l = 0;
			this.w = 0;
		} else {
			this.l = l;
			this.w = w;
		}
	}

	public int length() {
		return 2 * (l + w);
	}

	public int area() {
		return l * w;
	}

	public String toString() {
		return l + " " + w + " " + length() + " " + area();
	}

}

public class Main {

	public static void main(String[] args) {
		Scanner mi = new Scanner(System.in);

		while (mi.hasNext()) {
			Rect s = new Rect();
			String str = mi.nextLine();
			String[] data = str.split(" ");
			if (data.length == 1) {
				int l = Integer.parseInt(data[0]);
				s.Rect1(l);
			} else {
				int l = Integer.parseInt(data[0]);
				int w = Integer.parseInt(data[1]);
				s.Rect1(l, w);
			}
			System.out.println(s.toString());
		}
		mi.close();
	}
}

——————
余生还请多多指教!

  • 1
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值