Problem Description
根据给定的输入序列建立一棵平衡二叉树,求出建立的平衡二叉树的树根。
Input
输入一组测试数据。数据的第1行给出一个正整数N(n <= 20),N表示输入序列的元素个数;第2行给出N个正整数,按数据给定顺序建立平衡二叉树。
Output
输出平衡二叉树的树根。
Sample Input
5
88 70 61 96 120
Sample Output
70
提示:平衡二叉树是建立在二叉查找树的基础上的。二者的区别是,平衡二叉树左、右子树高度相差不能大于1。若大于1,则经旋转
AC代码:
#include<bits/stdc++.h>
using namespace std;
typedef struct tree
{
int data,h;
tree *l,*r;
} Tr;
int Dp(Tr *&root)
{
if(!root) return 1;
else return root->h;
}
void LL(Tr *&root)
{
Tr *root1=root->l;
root->l=root1->r;
root1->r=root;
root->h=max(Dp(root->l),Dp(root->r))+1;
root1->h=max(root->h,Dp(root1->l));
root=root1;
}
void RR(Tr *&root)
{
Tr *root1=root->r;
root->r=root1->l;
root1->l=root;
root->h=max(Dp(root->l),Dp(root->r))+1;
root1->h=max(root->h,Dp(root1->r));
root=root1;
}
void LR(Tr *&root)
{
RR(root->l);
LL(root);
}
void RL(Tr *&root)
{
LL(root->r);
RR(root);
}
Tr *Creat(Tr *&root,int x)
{
if(!root)
{
root=new Tr;
root->data=x;
root->l=root->r=NULL;
root->h=1;
}
else if(root->data>x)
{
Creat(root->l,x);
if(Dp(root->l)-Dp(root->r)>1)
{
if(root->l->data>x) LL(root);
else LR(root);
}
}
else
{
Creat(root->r,x);
if(Dp(root->r)-Dp(root->l)>1)
{
if(root->r->data<x) RR(root);
else RL(root);
}
}
root->h=max(Dp(root->l),Dp(root->r))+1;
}
int main()
{
int n,x;
Tr *root=NULL;
cin>>n;
while(n--)
{
cin>>x;
Creat(root,x);
}
cout<<root->data<<endl;
return 0;
}
#include<stdio.h>
typedef struct node
{
int data,h;
struct node *l,*r;
} Tr;
int Dp(Tr *root)
{
if(!root) return -1;
else return root->h;
}
int max(int a,int b)
{
if(a>b) return a;
else return b;
}
Tr *LL(Tr *root)
{
Tr *root1=root->l;
root->l=root1->r;
root1->r=root;
root->h=max(Dp(root->l),Dp(root->r))+1;
root1->h=max(root->h,Dp(root1->l))+1;
root=root1;
return root1;
}
Tr *RR(Tr *root)
{
Tr *root1=root->r;
root->r=root1->l;
root1->l=root;
root->h=max(Dp(root->l),Dp(root->r))+1;
root1->h=max(root->h,Dp(root1->r))+1;
root=root1;
return root1;
}
Tr *RL(Tr *root)
{
root->r=LL(root->r);
return RR(root);
}
Tr *LR(Tr *root)
{
root->l=RR(root->l);
return LL(root);
}
Tr *creat(Tr *root,int x)
{
if(!root)
{
root=(Tr *)malloc(sizeof(Tr));
root->data=x;
root->r=root->l=NULL;
root->h=1;
}
else if(root->data>x)
{
root->l=creat(root->l,x);
if(Dp(root->l)-Dp(root->r)>1)
{
if(root->l->data>x) root=LL(root);
else root=LR(root);
}
}
else
{
root->r=creat(root->r,x);
if(Dp(root->r)-Dp(root->l)>1)
{
if(root->r->data<x) root=RR(root);
else root=RL(root);
}
}
root->h=max(Dp(root->l),Dp(root->r))+1;
return root;
}
int main()
{
int n, x;
Tr *root=NULL;
scanf("%d",&n);
while(n--)
{
scanf("%d",&x);
root=creat(root,x);
}
printf("%d\n",root->data);
return 0;
}
————
余生还请多多指教!