PAT 甲级 1030 (Travel Plan)

题目要求

A traveler’s map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (≤500) is the number of cities (and hence the cities are numbered from 0 to N−1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost
where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:
For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

Sample Input:
4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20
Sample Output:
0 2 3 3 40

翻译

类似旅行商问题,从起点到终点,找最短路径,相同情况下找最小开销。

代码

#include<iostream>
#include<vector>
using namespace std;
vector<int> v[501],path,ans;
int dis[501][501],cos[501][501];
int n,m,s,d;
int mindis[501],mindist=9999,mincost=9999;
void dfs(int cur,int dist,int cost)
{
    if(dist>mindis[cur]) return;//及时止损
    path.emplace_back(cur);
    if(cur==d){//到目的地
        if(dist<mindist||(dist==mindist && cost<mincost)){
            ans=path;
            mincost=mindis[d]=cost;
            mindist=dist;
        }
    }
    else
    {
        if(mindis[cur]>dist) mindis[cur]=dist;
        for(int i:v[cur])
        {
            dfs(i,dist+dis[cur][i],cost+cos[cur][i]);
        }
    }
    path.pop_back();
}
int main()
{
    cin>>n>>m>>s>>d;
    int i,j,k,c;
    while (m--)
    {
        cin>>i>>j>>k>>c;
        v[i].emplace_back(j);
        v[j].emplace_back(i);
        dis[i][j]=dis[j][i]=k;
        cos[i][j]=cos[j][i]=c;
    }
    for(i=0;i<501;i++) mindis[i]=9999;
    dfs(s,0,0);
    for(int each:ans) cout<<each<<" ";
    cout<<mindist<<" ";
    cout<<mincost<<endl;
    system("pause");
}

思路

又是一道深度优先遍历的题目,找最短路径和最小开销。
如果到了目的地,判断这条路是否最优,是的话存储改路径,并对最小路径和最小开销进行更新。
如果没有到需要判断这条路是不是比之前走的短,对应函数最开始的及时止损。然后继续往下遍历。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值