1033. To Fill or Not to Fill (25)-PAT甲级真题

With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive numbers: Cmax​ (≤ 100), the maximum capacity of the tank; D (≤30000), the distance between Hangzhou and the destination city; Davg​ (≤20), the average distance per unit gas that the car can run; and N (≤ 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: Pi​, the unit gas price, and Di​ (≤D), the distance between this station and Hangzhou, for i=1,⋯,N. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print The maximum travel distance = X where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

Sample Input 1:

50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300

Sample Output 1:

749.17

Sample Input 2:

50 1300 12 2
7.10 0
7.00 600

Sample Output 2:

The maximum travel distance = 1200.00
#include<cstdio>
#include<algorithm>
#include<iostream>
using namespace std;
struct Node{
    double p, d;//单位油价,油站与城市间距
}node[510];
bool cmp( Node a, Node b ){
    return a.d < b.d;
}
int main(){
    double cmax, cd, dvag;//最大容量,城市间距离,每单位油可行驶路程
    int n;//加油站数
    scanf( "%lf%lf%lf%d", &cmax, &cd, &dvag, &n );
    int dmax = cmax * dvag;//满油可行驶距离
    for( int i = 0; i < n; i++ ){
        scanf( "%lf%lf", &node[i].p, &node[i].d );
    }
    node[n].d = cd;
    node[n].p = 0;
    sort( node, node + n, cmp );//按距离排序
    if(node[0].d!=0){
        printf("The maximum travel distance = 0.00");
        return 0;
    }
    double ammount=0, x=0, gas_remain=0;
    for( int i = 0; i < n; i++ ){
        if(node[i+1].d - node[i].d > dmax){//两站间距超出最远距离就直接返回
            printf("The maximum travel distance = %.2f", x + dmax);
            return 0;
        }
        int j = i+1, flag=i+1;
        while( node[j].d - node[i].d <= dmax ){
            if(node[j].p <= node[i].p){
                ammount+=((node[j].d - node[i].d)/dvag-gas_remain)*node[i].p;
                gas_remain=0.0;
                x+=node[j].d- node[i].d;
                i=j-1;//这一步是真无语,看了半天不知道哪错了,原来是后面i会自加的问题,可以直接去掉i++,这里的j和后面flag就不用减1了
                break;
            }
            if(node[j].p < node[flag].p)
                flag=j;
            j++;
        }
        if(i==j-1)
            continue;
        else {
            ammount+= (cmax-gas_remain) * node[i].p;
            gas_remain=cmax-(node[flag].d - node[i].d )/ dvag;
            x=node[flag].d;
            i=flag-1;
        }
    }
    printf("%.2f", ammount);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值