HDU 1003 Max Sum————动态规划 连续子序列和最大

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

 

大意:

一位数组,找出和最大的最长子序列和此序列的开头和结尾

 

思路:

建立一维dp数组,dp[i]的为终点为i的子序列的最大和。

找状态转移规律,

从dp[1]开始, dp[1] = a[1]。

然后 dp[2],有两种情况,要么是(a[1], a[2]), 要么是(a[2]),所以dp[2] = max(a[1]+a[2], a[2]), 把a[2]提出来, 就是dp[2] = a[2] +max(a[1], 0), 也就是dp[2] = a[2] + max(dp[1], 0);

然后看dp[3], dp[3] 有三种情况: ( a[1], a[2], a[3])    ( a[2], a[3] )    (a[3]), 所以dp[3]就是这三个数中最大的, 前两个数最大其实就是dp[2],所以最后是 dp[3] = a[3] + max(dp[2], 0);

那么dp[i] = a[i] + max(dp[i-1], 0)

 

#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<cstring>
#include<string>
#include<iostream>
#include<stack>
#include<queue>
#include<algorithm>
#include<map>
#include<list>
#include<vector>

#define INF 0x3f3f3f3f
#define MAXN 100005

using namespace std;

typedef struct
{
    int sum;
    int l;
    int r;
}node;

int main()
{
    int T, Case = 1;
    scanf("%d", &T);
    while(T--)
    {
        int n, a[MAXN], i, j;
        node dp[MAXN] = {0};
        scanf("%d", &n);
        for(i = 1; i <= n; i++)
        {
            scanf("%d", &a[i]);
        }
        dp[1].sum = a[1];
        dp[1].l = 1;
        dp[1].r = 1;
        for(i = 2; i <= n; i++)
        {
            if(dp[i-1].sum >= 0)
            {
                dp[i].sum = a[i] + dp[i-1].sum;
                dp[i].l = dp[i-1].l;
                dp[i].r = i;
            }
            else
            {
                dp[i].sum = a[i];
                dp[i].l = i;
                dp[i].r = i;
            }
        }
        int Max = -INF, maxi;
        for(i = 1; i <= n; i++)
        {
            if(dp[i].sum > Max)
            {
                Max = dp[i].sum;
                maxi = i;
            }
        }
        printf("Case %d:\n", Case++);
        printf("%d %d %d\n", dp[maxi].sum, dp[maxi].l, dp[maxi].r);
        if(T != 0) printf("\n");
    }

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值