Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.
Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.
Input
* Line 1: Two integers N and K, separated by a single space.
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.
Output
* Line 1: The integer representing the minimum number of times Bessie must shoot.
Sample Input
3 4
1 1
1 3
2 2
3 2
Sample Output
2
Hint
INPUT DETAILS:
The following diagram represents the data, where "X" is an asteroid and "." is empty space:
X.X
.X.
.X.
OUTPUT DETAILS:
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).
思路:
这是一道最小点覆盖问题, 匈牙利算法模板题。
(最小点覆盖问题 = 最大匹配问题)
刚开始根本没看出来和匈牙利算法有啥关系。
将行号看为左半边的节点,将列号看为右半边的节点,若(x,y)有小行星,那么链接左边的x和右边的y
然后就出现了一个二分图,然后求它的最大匹配就行。
AC代码:
#include<cstdio>
#include<algorithm>
#include<vector>
#include<cstring>
#define MAXN 505
#define INF 0x3f3f3f3f
using namespace std;
int n, k;
int match[MAXN];
bool edge[MAXN][MAXN], vis[MAXN];
int dfs(int u) {
for (int i = 1; i <= n; i++) {
if (vis[i] == false && edge[u][i] == true) {
vis[i] = true;
if (match[i] == 0 || dfs(match[i])) {
match[i] = u;
return 1;
}
}
}
return 0;
}
int main() {
scanf("%d%d", &n, &k);
for (int i = 1; i <= k; i++) {
int a, b;
scanf("%d%d", &a, &b);
edge[a][b] = true;
}
int sum = 0;
for (int i = 1; i <= n; i++) {
memset(vis, false, sizeof(vis));
if (dfs(i) == 1) {
sum++;
}
}
printf("%d\n", sum);
return 0;
}