PAT-1013-图的遍历

1013 Battle Over Cities
It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input

3 2 3
1 2
1 3
1 2 3

Sample Output

1
0
0

谷歌中文翻译:

在战争中,所有城市都必须通过高速公路连接起来,这一点至关重要。如果一个城市被敌人占领,则从该城市/往该城市的所有高速公路都将关闭。我们必须立即知道是否需要维修其他高速公路以保持其余城市的连通性。在标记了所有剩余高速公路的城市地图上,您应该告诉我们需要快速修复的高速公路数量。

例如,如果我们有3个城市和2条连接city1-city2和city1-city3的高速公路。然后,如果city1被敌人占领,我们必须修复1条公路,即公路city2-city3。

输入值

每个输入文件包含一个测试用例。每种情况都从包含3个数字N(<1000),M和K的行开始,分别是城市总数,剩余高速公路数量和要检查的城市数量。然后是M条线,每条线用2个整数描述一条高速公路,这是该高速公路连接的城市的数量。城市从1到N编号。最后一行包含K号,代表我们关注的城市。

输出量

对于K个城市中的每个城市,如果一条城市丢失,则需要对一条高速公路上的高速公路数量进行修补。

思路:
我的…一个数据点超时了呃呃
思想就是他们的连通分量数-1,因为当a个互相分立的连通分量需要变为连通图的时候,只需要添加a-1个路线,就能让他们相连。
柳神思路

#include<bits/stdc++.h>
using namespace std;

const int MAX_N = 1010;
int v[MAX_N][MAX_N];
bool visit[MAX_N];
int n, m, k;	//n个城市 m条道路 k个关注的城市 
 
void init() {
	cin >> n >> m >> k;
	int a, b;	//记录道路起始 
	
	for(int i = 0; i < m; i++) {
		cin >> a >> b;
		v[a][b] = v[b][a] = 1;
	}
}

void dfs(int index) {
	visit[index] = true;
	for(int i = 1; i <= n; i++) {
		if(visit[i] == false && v[index][i] == 1){
			dfs(i);
		}
	}
} 

int main() {
	init(); 
	for(int i = 0; i < k; i++) {
		int t; //记录当前第t个城市
		//每一次都要将之前访问记录清除 
		fill(visit, visit + MAX_N, false);
		cin >> t;
		int cnt = 0;	//计数
		visit[t] = true;	//当前结点已访问
		for(int j = 1; j <= n; j++) {
			if(visit[j] == false) {
				dfs(j);
				cnt++;	//求连通分量 
			}
		} 
		cout << cnt - 1 << endl;
	} 	
	return 0;	
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值