《算法笔记》4.4小节——算法初步->贪心

问题 D: Repair the Wall


题目描述
Long time ago , Kitty lived in a small village. The air was fresh and the scenery was very beautiful. The only thing that troubled her is the typhoon.
When the typhoon came, everything is terrible. It kept blowing and raining for a long time. And what made the situation worse was that all of Kitty’s walls were made of wood.
One day, Kitty found that there was a crack in the wall. The shape of the crack is
a rectangle with the size of 1×L (in inch). Luckly Kitty got N blocks and a saw(锯子) from her neighbors.
The shape of the blocks were rectangle too, and the width of all blocks were 1 inch. So, with the help of saw, Kitty could cut down some of the blocks(of course she could use it directly without cutting) and put them in the crack, and the wall may be repaired perfectly, without any gap.
Now, Kitty knew the size of each blocks, and wanted to use as fewer as possible of the blocks to repair the wall, could you help her ?
输入
The problem contains many test cases, please process to the end of file( EOF ).
Each test case contains two lines.
In the first line, there are two integers L(0<L<1000000000) and N(0<=N<600) which
mentioned above.
In the second line, there are N positive integers. The ith integer Ai(0<Ai<1000000000 ) means that the ith block has the size of 1×Ai (in inch).
输出
For each test case , print an integer which represents the minimal number of blocks are needed.
If Kitty could not repair the wall, just print “impossible” instead.
样例输入 Copy
2 2
12 11
14 3
27 11 4
109 5
38 15 6 21 32
5 3
1 1 1
样例输出 Copy
1
1
5
impossible


**题意分析:本题是一道英文题目,但是其单词句子都比较基础,如果这都不能看懂的话,建议可以多刷英文题目,就会发现这些题目的单词都是很常见的一些专用名词什么的 ***
**正文:此题意思为有一块1
L的墙坏了,要用借来的砖块(就理解为砖块了,不接受反驳 )来补这面墙。对于输入的解释:第一行第一个数为需要补的墙的长度,第二个数字是砖块的总数。第二行的两个数字是砖块的长度(宽度都是1inch)。多组输入每组输入对应一个输出为需要的最少的砖块数

  • 思路分析

**两种情况:
1.墙的宽度小于最大砖块的宽度,则直接return 1(只需要输出1就好,不用管是否拿这块最大的砖去补墙哦)
2.墙的宽度大于最大的砖块,那么就至少需要两块砖来补墙了。这时候把墙的宽度处理为原宽度-当前砖块宽度,意在寻找可以把剩下的墙补充完整,如果剩余墙的宽度小于任意砖块的宽度了,说明当前所遍历的砖块完全可以补住这面墙。但是如果遍历完所有砖块,剩余的未补墙的宽度还是大于0,则说明我们的砖块不够了,输出impossible即可。
代码时间:

#include <iostream>
#include <cstdio>
#include <algorithm>
const int maxn=1000;
int str[maxn];
int cot=0;
bool cmp(int a,int b)//按砖块宽度从大大小排列
{
    return a>b;
}
using namespace std;
int main()
{
    long long l;
    int n;
    while(scanf("%lld%d",&l,&n)!=EOF)
    {
        cot=0;
        for(int i=0; i<n; i++)
        {
            scanf("%d",&str[i]);
        }
        sort(str,str+n,cmp);//把砖块大小从大到小排列
        int i;
        for( i=0; i<n; i++)
        {
            if(l<=str[i]) //如果l小于任意一块砖的宽
            {
                cot++;
                break;
            }

            else
            {
                l-=str[i];//未补墙的宽度
                cot++;
            }
        }
        if(i==n)//遍历结束,未能补住墙
        {
            printf("impossible\n");
        }
        else//可以补住墙
            printf("%d\n",cot);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值