POJ 1930 Dead Fraction(gcd+无限循环小数变最简分数)

Description

Mike is frantically scrambling to finish his thesis at the last minute. He needs to assemble all his research notes into vaguely coherent form in the next 3 days. Unfortunately, he notices that he had been extremely sloppy in his calculations. Whenever he needed to perform arithmetic, he just plugged it into a calculator and scribbled down as much of the answer as he felt was relevant. Whenever a repeating fraction was displayed, Mike simply reccorded the first few digits followed by “…”. For instance, instead of “1/3” he might have written down “0.3333…”. Unfortunately, his results require exact fractions! He doesn’t have time to redo every calculation, so he needs you to write a program (and FAST!) to automatically deduce the original fractions.
To make this tenable, he assumes that the original fraction is always the simplest one that produces the given sequence of digits; by simplest, he means the the one with smallest denominator. Also, he assumes that he did not neglect to write down important digits; no digit from the repeating portion of the decimal expansion was left unrecorded (even if this repeating portion was all zeroes).
Input

There are several test cases. For each test case there is one line of input of the form “0.dddd…” where dddd is a string of 1 to 9 digits, not all zero. A line containing 0 follows the last case.
Output

For each case, output the original fraction.
Sample Input

0.2…
0.20…
0.474612399…
0
Sample Output

2/9
1/5
1186531/2500000
Hint

Note that an exact decimal fraction has two repeating expansions (e.g. 1/5 = 0.2000… = 0.19999…).

题意:把无限循环小数变最简分数,但不确定循环节是哪几位,要求输出分母最小的分数。
参考链接

#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
#include <iostream>
#include <cmath>
#include <vector>
#include <map>
#include <stack>
#include <queue>
using namespace std;
typedef long long ll;
const int MAX=0x3f3f3f3f;
string a;

ll gcd(ll a,ll b){
	return b==0?a:gcd(b,a%b);
}

int main(){
	while(cin>>a){
		if(a=="0") break;
		ll ans_cnt=0,ans_d=MAX;
		int len=a.length(),point;
		for(int i=2;i<len;i++){
			if(a[i]=='.'){
				point=i;
				break;
			}
		}
		for(int i=2;i<point;i++){
			
			ll cnt=0,d=0;
			for(int j=i;j<point;j++){
				cnt=cnt*10+(a[j]-'0');
				d=d*10+9;
			}
			ll num=0;
			for(int j=2;j<i;j++){
				num=num*10+(a[j]-'0');
			}
			cnt+=num*d;
			for(int j=2;j<i;j++){
				d*=10;
			}
			ll t=gcd(cnt,d);
			cnt/=t;
			d/=t;
			if(d<ans_d){
				ans_d=d;
				ans_cnt=cnt;
			}
		}
		cout<<ans_cnt<<"/"<<ans_d<<endl;
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值