Sunscreen POJ - 3614 优先队列+贪心

To avoid unsightly burns while tanning, each of the C (1 ≤ C ≤ 2500) cows must cover her hide with sunscreen when they’re at the beach. Cow i has a minimum and maximum SPF rating (1 ≤ minSPFi ≤ 1,000; minSPFi ≤ maxSPFi ≤ 1,000) that will work. If the SPF rating is too low, the cow suffers sunburn; if the SPF rating is too high, the cow doesn’t tan at all…

The cows have a picnic basket with L (1 ≤ L ≤ 2500) bottles of sunscreen lotion, each bottle i with an SPF rating SPFi (1 ≤ SPFi ≤ 1,000). Lotion bottle i can cover coveri cows with lotion. A cow may lotion from only one bottle.

What is the maximum number of cows that can protect themselves while tanning given the available lotions?

Input

  • Line 1: Two space-separated integers: C and L
  • Lines 2…C+1: Line i describes cow i’s lotion requires with two integers: minSPFi and maxSPFi
  • Lines C+2…C+L+1: Line i+C+1 describes a sunscreen lotion bottle i with space-separated integers: SPFi and coveri

Output
A single line with an integer that is the maximum number of cows that can be protected while tanning

Sample Input
3 2
3 10
2 5
1 5
6 2
4 1
Sample Output
2
思路:奶牛按照能够忍受阳光强度的最小值从小到大排序,防晒霜也按照能够抵御的阳光强度从小到大排序,符合 奶牛的最小值 小于或等于防晒霜的值,就将奶牛的最大值放入优先队列之中。用到从小到大排序的优先队列。

#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
#include <iostream>
#include <cmath>
#include <vector>
#include <map>
#include <stack>
#include <queue>
using namespace std;
typedef long long ll;
const int MAX=0x3f3f3f3f;
const int N=2555;
typedef pair<int,int> P;
priority_queue<int,vector<int>,greater<int> > q;  //需要空格 
P cow[N],bot[N];
int main(){
	int c,l;
	cin>>c>>l;
	for(int i=0;i<c;i++){
		cin>>cow[i].first>>cow[i].second;
	}
	for(int i=0;i<l;i++){
		cin>>bot[i].first>>bot[i].second;
	}
	sort(cow,cow+c);
	sort(bot,bot+l);
	int ans=0,k=0;
	for(int i=0;i<l;i++){
		while(k<c&&cow[k].first<=bot[i].first){
			q.push(cow[k].second);
			k++;
		}
		while(!q.empty()&&bot[i].second!=0){
			int now=q.top();
			q.pop();
			if(now<bot[i].first) continue;
			else{
				ans++;
				bot[i].second--;
			}
		}
	}
	cout<<ans<<endl;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值