2019湖南多校3 What Goes Up Must Come Down (树状数组)

What Goes Up Must Come Down (树状数组)


题目链接
Description:
Several cards with numbers printed on them are lined up on the table.

We’d like to change their order so that first some are in non-decreasing order of the numbers on them, and the rest are in non-increasing order. For example, (1, 2, 3, 2, 1), (1, 1, 3, 4, 5, 9, 2), and (5, 3, 1) are acceptable orders, but (8, 7, 9) and (5, 3, 5, 3) are not.

To put it formally, with n the number of cards and bi the number printed on the card at the i-th position (1 ≤ i ≤ n) after reordering, there should exist k ∈ {1, …n} such that (bi ≤ bi + 1∀i ∈ {1, …k − 1}) and (bibi+1∀i1,…k−1) hold.

For reordering, the only operation allowed at a time is to swap the positions of an adjacent card pair. We want to know the minimum number of swaps required to complete the reorder.

Input:
An integer n in the first line is the number of cards (1 ≤ n ≤ 100000). Integers a1 through an in the second line are the numbers printed on the cards, in the order of their original positions (1 ≤ ai ≤ 100000)
Output:
Output in a line the minimum number of swaps required to reorder the cards as specified.
Sample Input 1
7
3 1 4 1 5 9 2
Sample Output 1
3
Sample Input 2
9
10 4 6 3 15 9 1 1 12
Sample Output 2
8
Sample Input 3
8
9 9 8 8 7 7 6 6
Sample Output 3
0
Sample Input 4
6
8 7 2 5 4 6
Sample Output 4
4

题意:给你一串数字,每次只能交换相邻两个数字的位置,需要把这串数字分成前面不递减,后面不递增的两部分。求最小操作次数。

考虑每一个数字,它要么在左半部分,要么在右半部分,如果它在左半部分,那它的左边所有比它大的数字都一定会和它有一次交换,右半部分同理。建两个树状数组,一个从左边扫一次,一个从右边扫一次,记录每个数字左右比它大的数字个数,然后取Min之后求和即可。
(然而比赛的时候线段树和树状数组都WA了,线下发现了出错的数据之后才修正了思路

AC代码

#include<iostream>
#include<cstdio>
#define ll long long
using namespace std;
const int maxn = 1e6 + 50;
ll z[maxn]={0};
ll y[maxn]={0};
int n;
ll a[maxn];
ll lowbit(ll x){
	return x&(-x);
}
ll query(ll i,ll t[]){
	ll ans = 0;
	while(i){
		ans += t[i];
		i-=lowbit(i);
	}
	return ans;
}
void add(ll i,ll x,ll t[]){
	while(i < maxn){
		t[i]+=x;
		i+=lowbit(i);
	}
}
ll num1[maxn];
ll num2[maxn];
void sol(){
	for(int i = n-1;i >= 0;--i){
		num1[i] = query(maxn-a[i]-1,y);
		add(maxn-a[i],1,y);
	}
	ll ans = 0;
	for(int i = 0;i < n;++i){
		num2[i] = query(maxn-a[i]-1,z);
		add(maxn - a[i],1,z);
	}
	for(int i = 0;i < n;++i) ans+=min(num1[i],num2[i]);
	cout<<ans<<endl;
}
int main(){
	cin>>n;
	for(int i = 0;i < n;++i) scanf("%lld",&a[i]);
	sol();
} 
  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值