使用路由标记控制路由过滤

实验旨在掌握通过路由标记控制路由过滤。配置包括接口IP、路由协议基础设置、路由重分发。在R4上应用路由标记过滤,避免学习1.1.0.0/24和1.1.2.0/24网络。路由标记过滤分为标记配置和过滤两步,简化了客户端的路由筛选,减少ACL使用,有效维护路由更新。
摘要由CSDN通过智能技术生成

实验目的:掌握使用路由标记控制路由过滤

实验拓扑:

步骤1:接口ip配置:

R1(config)#interface f0/0
R1(config-if)#ip address 12.12.12.1 255.255.255.0
R1(config-if)#no shutdown 
R1(config)#interface loopback 0
R1(config-if)#ip add 1.1.0.1 255.255.255.0
R1(config-if)#interface loopback 1        
R1(config-if)#ip address 1.1.1.1 255.255.255.0
R1(config-if)#interface loopback 2            
R1(config-if)#ip address 1.1.2.1 255.255.255.0
R1(config-if)#interface loopback 3            
R1(config-if)#ip address 1.1.3.1 255.255.255.0

R2(config)#interface f0/0
R2(config-if)#ip address 12.12.12.2 255.255.255.0
R2(config-if)#no shutdown 
R2(config-if)#interface f0/1                     
R2(config-if)#ip address 23.23.23.2 255.255.255.0
R2(config-if)#no sh
R2(config-if)#no shutdown 

R3(config)#interface f0/1
R3(config-if)#ip address 23.23.23.3 255.255.255.0
R3(config-if)#no shutdown 
R3(config-if)#interface f0/0                     
R3(config-if)#ip address 34.34.34.3 255.255.255.0
R3(config-if)#no shutdown 

R4(config)#interface f0/0
R4(config-if)#ip add 34.34.34.4 255.255.255.0
R4(config-if)#no shutdown

步骤2:路由协议基础配置

R1(config)#router eigrp 10
R1(config-router)#no auto-summary 
R1(config-router)#network 12.12.12.0 0.0.0.255
R1(config-router)#network 1.1.0.0 0.0.0.255
R1(config-router)#network 1.1.1.0 0.0.0.255
R1(config-router)#network 1.1.2.0 0.0.0.255
R1(config-router)#network 1.1.3.0 0.0.0.255

R2(config)#router  eigrp 10
R2(config-router)#no auto-summary 
R2(config-router)#network 12.12.12.0 0.0.0.255
R2(config-router)#router ospf 1
R2(config-router)#network 23.23.23.0 0.0.0.255 area 0

R3(config)#router ospf 1
R3(config-router)#network 23.23.23.0 0.0.0.255 area 0
R3(config-router)#router  rip
R3(config-router)#no auto-summary  
R3(config-router)#version 2
R3(config-router)#network 34.34.34.0

R4(config)#router rip
R4(config-router)#no auto-summary 
R4(config-router)#version 2
R4(config-router)#network 34.34.34.0

步骤3:路由重分发

R2(config)#router ospf 1
R2(config-router)#redistribute eigrp 10 subnets 
R2(config-router)#router eigrp 10
R2(config-router)#redistribute ospf 1 metric 10000 100 255 1 1500

R3(config)#router ospf 1
R3(config-router)#redistribute rip  subnets 
R3(config-router)#router rip
R3(config-router)#redistribute ospf 1 metric 10

在R4上查看路由表,确认路由重发布:

R4#show ip route 

Gateway of last resort is not set

     34.0.0.0/24 is subnetted, 1 subnets
C       34.34.34.0 is directly connected, FastEthernet0/0
     1.0.0.0/24 is subnetted, 4 subnets
R       1.1.0.0 [120/10] via 34.34.34.3, 00:00:11, FastEthernet0/0
R       1.1.1.0 [120/10] via 34.34.34.3, 00:00:11, FastEthernet0/0
R       1.1.2.0 [120/10] via 34.34.34.3, 00:00:11, FastEthernet0/0
R       1.1.3.0 [120/10] via 34.34.34.3, 00:00:11, FastEthernet0/0
     23.0.0.0/24 is subnetted, 1 subnets
R       23.23.23.0 [120/10] via 34.34.34.3, 00:00:11, FastEthernet0/0
     12.0.0.0/24 is subnetted, 1 subnets
R       12.12.12.0 [120/10] via 34.34.34.3, 00:00:14, FastEthernet0/0

根据拓扑配置得知:1.1.0.0/24和1.1.2.0/24的网络不允许被R4学习。除了Distribute-list或Route-map配置可以了实现此路由过滤功能。也可以通过配置路由标记,来实现路由过滤的功能。

使用路由标记的过滤,分为两个步骤。一、服务器端路由器配置标记。二、客户端路由器根据标记进行过滤。

步骤4:在R2上配置分配路由标记:

R2(config)#access-list 1 permit 1.1.0.0 0.0.0.255
R2(config)#access-list 1 permit 1.1.2.0 0.0.0.255
//使用ACL标识出需要设置标记的路由。
R2(config)#route-map set_tag deny 10
R2(config-route-map)#match ip address 1
//为匹配ACL 1的路由条目,分配标记为1
R2(config-route-map)#set tag 1
R2(config)#route-map set_tag permit 20
R2(config)#router  ospf 1
R2(config-router)#redistribute eigrp 10 subnets route-map set_tag
//在路由重发布时调用路由图,进行标记的嵌入。

步骤5:在R3上,配置route-map通过标记来进行路由过滤:

R3(config)#route-map match_tag deny 10
R3(config-route-map)#match tag 1
//对于标记为1的路由,进行过滤处理
R3(config-route-map)#route-map match_tag permit 20
//其它的路由无条件转发
R3(config)#router rip
R3(config-router)#redistribute ospf 1 metric 10 route-map match_tag
//在路由重发布时调用路由图进行了过滤。

查看R4的路由表,确认路由过滤:

R4#show ip route 

Gateway of last resort is not set

     34.0.0.0/24 is subnetted, 1 subnets
C       34.34.34.0 is directly connected, FastEthernet0/0
     1.0.0.0/24 is subnetted, 2 subnets
R       1.1.1.0 [120/10] via 34.34.34.3, 00:00:00, FastEthernet0/0
R       1.1.3.0 [120/10] via 34.34.34.3, 00:00:00, FastEthernet0/0
     23.0.0.0/24 is subnetted, 1 subnets
R       23.23.23.0 [120/10] via 34.34.34.3, 00:00:00, FastEthernet0/0
     12.0.0.0/24 is subnetted, 1 subnets
R       12.12.12.0 [120/10] via 34.34.34.3, 00:00:00, FastEthernet0/0

路由标记可以简单的实现路由预先分类,客户端仅需要简单匹配标记而不需要编写大量的ACL来标识路由。通过此配置,可以有效的维护网络的路由更新。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值