多区域的IS-IS 配置与详解

该博客详细介绍了IS-IS工作原理,包括配置流程、路由器角色修改及其对邻居关系和DIS选举的影响。通过实验拓扑和具体配置,展示了如何在多区域环境中优化路由表,并分析了设备角色变化后的路由表更新情况。
摘要由CSDN通过智能技术生成

实验目的

1、熟悉IS-IS的工作原理。

2、熟悉IS-IS的配置流程及查看流程。

3、熟悉路由器角色的修改方式及最后对邻居关系影响及DIS的修改。

实验拓扑

​​​​​​​ 

接口ip配置:

R1(config)#interface f0/0
R1(config-if)#ip address 123.123.123.1 255.255.255.0
R1(config-if)#no shutdown 
R1(config)#interface loopback 0
R1(config-if)#ip address 1.1.1.1 255.255.255.0

R2(config)#interface f0/0
R2(config-if)#ip address 123.123.123.2 255.255.255.0
R2(config-if)#no shutdown 
R2(config-if)#interface f0/1                        
R2(config-if)#ip address 24.24.24.2 255.255.255.0
R2(config-if)#no shutdown 

R3(config)#interface f0/0
R3(config-if)#ip address 123.123.123.3 255.255.255.0
R3(config-if)#no shutdown 
R3(config-if)#interface f0/1                        
R3(config-if)#ip add 35.35.35.3 255.255.255.0
R3(config-if)#no shutdown

R4(config)#interface f0/1
R4(config-if)#ip address 24.24.24.4 255.255.255.0
R4(config-if)#no shutdown 
R4(config)#interface loopback 0
R4(config-if)#ip address 4.4.4.4 255.255.255.0

R5(config)#interface f0/1
R5(config-if)#ip address 35.35.35.5 255.255.255.0
R5(config-if)#no shutdown 
R5(config-if)#interface f0/0                     
R5(config-if)#ip address 56.56.56.5 255.255.255.0
R5(config-if)#no shutdown 

R6(config)#interface f0/0
R6(config-if)#ip address 56.56.56.6 255.255.255.0
R6(config-if)#no shutdown 

isis配置:

R1(config)#router isis
R1(config-router)#net 49.0064.0000.0000.0001.00
R1(config-if)#interface f0/0
R1(config-if)#ip router isis
R1(config)#interface loopback 0
R1(config-if)#ip router isis  

R2(config)#router isis
R2(config-router)#net 49.0064.0000.0000.0002.00  
R2(config)#interface f0/0
R2(config-if)#ip router isis
R2(config-if)#interface f0/1
R2(config-if)#ip router isis

R3(config)#router isis
R3(config-router)#net 49.0064.0000.0000.0003.00 
R3(config)#interface range f0/0 - 1
R3(config-if-range)#ip router isis

R4(config)#router isis 
R4(config-router)#net 49.00c8.0000.0000.0004.00   
R4(config)#interface f0/1
R4(config-if)#ip router isis
R4(config-if)#interface lo0 
R4(config-if)#ip router isis

R5(config)#router isis
R5(config-router)#net 49.00ff.0000.0000.0005.00  
R5(config)#interface range f0/0 - 1
R5(config-if-range)#ip router isis

R6(config)#router isis
R6(config-router)#net 49.00ff.0000.0000.0006.00   
R6(config)#interface f0/0
R6(config-if)#ip router isis

校验IS-IS 邻接关系及路由信息是否学习。

R1#show clns neighbors 

System Id      Interface   SNPA                State  Holdtime  Type Protocol
R3             Fa0/0       c203.0f4d.0000      Up     9         L1L2 IS-IS
//此处显示R1与R3 在E0/0口建立了 L1 / L2 邻接关系
R2             Fa0/0       c202.0f49.0000      Up     29        L1L2 IS-IS
//此处显示R1与R2 在E0/0口建立了 L1 / L2 邻接关系
R1#show ip route isis
     35.0.0.0/24 is subnetted, 1 subnets
i L1    35.35.35.0 [115/20] via 123.123.123.3, FastEthernet0/0
     4.0.0.0/24 is subnetted, 1 subnets
i L2    4.4.4.0 [115/30] via 123.123.123.2, FastEthernet0/0
     24.0.0.0/24 is subnetted, 1 subnets
i L1    24.24.24.0 [115/20] via 123.123.123.2, FastEthernet0/0
     56.0.0.0/24 is subnetted, 1 subnets
i L2    56.56.56.0 [115/30] via 123.123.123.3, FastEthernet0/0
//此处R1已经学习其它区域的路由,但是请关心下开销的由来
R4#show clns neighbors 

System Id      Interface   SNPA                State  Holdtime  Type Protocol
R2             Fa0/1       c202.0f49.0001      Up     29        L2   IS-IS
//此处显示R4与R2 在E0/0口建立了L2 邻接关系
R4#show ip route isis
     1.0.0.0/24 is subnetted, 1 subnets
i L2    1.1.1.0 [115/30] via 24.24.24.2, FastEthernet0/1
     35.0.0.0/24 is subnetted, 1 subnets
i L2    35.35.35.0 [115/30] via 24.24.24.2, FastEthernet0/1
     56.0.0.0/24 is subnetted, 1 subnets
i L2    56.56.56.0 [115/40] via 24.24.24.2, FastEthernet0/1
     123.0.0.0/24 is subnetted, 1 subnets
i L2    123.123.123.0 [115/20] via 24.24.24.2, FastEthernet0/1
//如上现象表明R4已经正常学习区域间
R6#show clns neighbors 

System Id      Interface   SNPA                State  Holdtime  Type Protocol
R5             Fa0/0       c205.0f4f.0000      Up     26        L1L2 IS-IS
R6#show ip route isis
     1.0.0.0/24 is subnetted, 1 subnets
i L2    1.1.1.0 [115/40] via 56.56.56.5, FastEthernet0/0
     35.0.0.0/24 is subnetted, 1 subnets
i L1    35.35.35.0 [115/20] via 56.56.56.5, FastEthernet0/0
     4.0.0.0/24 is subnetted, 1 subnets
i L2    4.4.4.0 [115/50] via 56.56.56.5, FastEthernet0/0
     24.0.0.0/24 is subnetted, 1 subnets
i L2    24.24.24.0 [115/40] via 56.56.56.5, FastEthernet0/0
     123.0.0.0/24 is subnetted, 1 subnets
i L2    123.123.123.0 [115/30] via 56.56.56.5, FastEthernet0/0
//如上现象表明R6已经正常学习区域间及区域内路由

完成R6设备角色的指定,达到优化路由表的目的。

R6(config)#router isis
R6(config-router)#is-type level-1

此时我们去关注R6 邻接关系的变化:

R6#show clns neighbors 

System Id      Interface   SNPA                State  Holdtime  Type Protocol
R5             Fa0/0       c205.0f4f.0000      Up     27        L1   IS-IS
//如上现象表明,现在R6因为路由器角色的变化,只和R5建立L1邻接关系

此时我们最终校验R6路由表变化;

R6#show ip route isis 
     35.0.0.0/24 is subnetted, 1 subnets
i L1    35.35.35.0 [115/20] via 56.56.56.5, FastEthernet0/0
i*L1 0.0.0.0/0 [115/10] via 56.56.56.5, FastEthernet0/0

如上现象表明当前设备已经从L1/L2 角色设备获取缺省路由,且不在学习L2路由。


影响 R1 R2 R3间DIS的选举。

R1#show isis neighbors 

System Id      Type Interface   IP Address      State Holdtime Circuit Id
R3             L1   Fa0/0       123.123.123.3   UP    9        R3.01              
R3             L2   Fa0/0       123.123.123.3   UP    8        R3.01              
R2             L1   Fa0/0       123.123.123.2   UP    24       R3.01              
R2             L2   Fa0/0       123.123.123.2   UP    23       R3.01 
//如上现象表明R1、R2、R3的DIS是R3。

R1(config)#interface f0/0
R1(config-if)#isis priority 127
//用来修改接口DIS优先级

此时我们再次校验R1的邻居表,查看DIS信息。

R1#show isis neighbors 

System Id      Type Interface   IP Address      State Holdtime Circuit Id
R3             L1   Fa0/0       123.123.123.3   UP    22       R1.01              
R3             L2   Fa0/0       123.123.123.3   UP    22       R1.01              
R2             L1   Fa0/0       123.123.123.2   UP    23       R1.01              
R2             L2   Fa0/0       123.123.123.2   UP    23       R1.01   
//如上现象表明DIS已经被R1取代。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值