2005ACM练习题第几天

Problem Description
给定一个日期,输出这个日期是该年的第几天。
Input
输入数据有多组,每组占一行,数据格式为YYYY/MM/DD组成,具体参见sample input ,另外,可以向你确保所有的输入数据是合法的。
Output
对于每组输入数据,输出一行,表示该日期是该年的第几天。
Sample Input
1985/1/20
2006/3/12
Sample Output
20
71

#include<stdio.h>
void n(int b,int c);
void m(int b,int c);
main()
{int a,b,c;
while(scanf("%d/%d/%d",&a,&b,&c)!=EOF)
{
if((a%4==0&&a%100!=0)||a%400==0)
m(b,c);
else 
n(b,c);
}
}
void m(int b,int c)
{switch(b)
{
case 12: c+=31;
case 11: c+=30;
case 10: c+=31;
case 9: c+=30;
case 8: c+=31;
case 7: c+=31;
case 6: c+=30;
case 5: c+=31;
case 4: c+=30;
case 3: c+=31;
case 2: c+=29;
case 1: c=c;
}
printf("%d\n",c);
}

void n(int b,int c)
{switch(b)
{
case 12: c+=31;
case 11: c+=30;
case 10: c+=31;
case 9: c+=30;
case 8: c+=31;
case 7: c+=31;
case 6: c+=30;
case 5: c+=31;
case 4: c+=30;
case 3: c+=31;
case 2: c+=28;
case 1: c=c;
}
printf("%d\n",c);
}
#include <stdio.h>
int main()
{
    int a,b,c,n,i;
    int month_day[12] = {31,28,31,30,31,30,31,31,30,31,30,31};
    while(scanf("%d/%d/%d",&a,&b,&c)!=EOF){
        n=0;
        for(i=0;i<m-1;i++)
            n+=month_day[i];
        n+=c;
        if((y%100!=0&&y%4==0)||y%400==0)
            if(m>2)
                n+=1;
        printf("%d\n",n);
    }
    return 0;
}
#include <stdio.h>
int main()
{
	int y,m,d;
	int a=1,s=0;
	while(scanf("%d/%d/%d",&y,&m,&d)!=EOF)
	{
		if(y%4==0 && y%100!=0 || y%400==0)
		{
            a=0;
		}
		int a[12]={31,28,31,30,31,30,31,31,30,31,30,31};
		int b[12]={31,29,31,30,31,30,31,31,30,31,30,31};
		if(a)
		{
			for(int i=0;i<m-1;i++)
			{
				s+=a[i];
			}
			s+=d;
			printf("%d\n",s);
		}
		else
		{
			for(int i=0;i<m-1;i++)
			{
				s+=b[i];
			}
			s+=d;
			printf("%d\n",s);
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值