算法:古老的密码,UVa1339题解

先粘一下题目

Ancient Roman empire had a strong government system with various departments, including a secret
service department. Important documents were sent between provinces and the capital in encrypted
form to prevent eavesdropping. The most popular ciphers in those times were so called substitution
cipher and permutation cipher.
Substitution cipher changes all occurrences of each letter to some other letter. Substitutes for all
letters must be different. For some letters substitute letter may coincide with the original letter. For
example, applying substitution cipher that changes all letters from ‘A’ to ‘Y’ to the next ones in the
alphabet, and changes ‘Z’ to ‘A’, to the message “VICTORIOUS” one gets the message “WJDUPSJPVT”.
Permutation cipher applies some permutation to the letters of the message. For example, applying the permutation ⟨2, 1, 5, 4, 3, 7, 6, 10, 9, 8⟩ to the message “VICTORIOUS” one gets the message
“IVOTCIRSUO”.
It was quickly noticed that being applied separately, both substitution cipher and permutation
cipher were rather weak. But when being combined, they were strong enough for those times. Thus,
the most important messages were first encrypted using substitution cipher, and then the result was
encrypted using permutation cipher. Encrypting the message “VICTORIOUS” with the combination of
the ciphers described above one gets the message “JWPUDJSTVP”.
Archeologists have recently found the message engraved on a stone plate. At the first glance it
seemed completely meaningless, so it was suggested that the message was encrypted with some substitution and permutation ciphers. They have conjectured the possible text of the original message that
was encrypted, and now they want to check their conjecture. They need a computer program to do it,
so you have to write one.
Input
Input file contains several test cases. Each of them consists of two lines. The first line contains the
message engraved on the plate. Before encrypting, all spaces and punctuation marks were removed, so
the encrypted message contains only capital letters of the English alphabet. The second line contains
the original message that is conjectured to be encrypted in the message on the first line. It also contains
only capital letters of the English alphabet.
The lengths of both lines of the input file are equal and do not exceed 100.
Output
For each test case, print one output line. Output ‘YES’ if the message on the first line of the input file
could be the result of encrypting the message on the second line, or ‘NO’ in the other case.
Sample Input
JWPUDJSTVP
VICTORIOUS
MAMA
ROME
HAHA
HEHE
AAA
AAA
NEERCISTHEBEST
SECRETMESSAGES
Sample Output

解题思路:按照题目给定的示例输入来看给定的两个输入串都是大写字母并且长度相等,通过对其中一个字符串进行某种映射变为另一个字符串,如果可以的话,即输出“YES”,如果不行,就要输处“NO”,因此我们直接计算两个字符串中各个字母的个数,分别将个数赋值给两个数组,由于并没有规定是哪种映射方式,因此只要将两个数组进行重拍后,如果数组相等,即符合题意,输出“YES”
直接粘答案

#include <iostream>
#include <string>
#include <algorithm>
using namespace std;
string s1="",s2="";
int main()
{
     int flag=1;  //标志位,判断最后两个数组是否相同
    while(cin>>s1>>s2){
        int a[30]={0};   //两个数组分别记录字母出现的次数
        int b[30]={0};
        for(int i=0;i<s1.length();i++){
//            if(s1[i]=='A') s1[i]='Z';   这里有个误区,可能是我理解问题,错误的地方可以直接忽略
//            else s1[i]--;
            a[s1[i]-'A']++;
            b[s2[i]-'A']++;
        }
        sort(a,a+30);  //对两个数组进行排序
        sort(b,b+30);
        for(int i=1;i<30;i++)
            if(a[i]!=b[i]) flag=0;
        if(flag) cout<<"YES"<<endl;
        else {
                cout<<"NO"<<endl;
                flag=1;
        }
    }
    return 0;
}

**注意事项:**这里面有一个问题,就是题目给定的映射方式是不确定的,也可以说是任意的,因此只要保证某两个字母个数相等,之间即可产生映射关系。所以我们只需要判断两个字符串中每个字母出现的个数的数组重排后是否相等即可。看来英语真的很重要啊。。。

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值