[kuangbin带你飞]专题五 并查集 C - How Many Tables

C - How Many Tables

题目链接:https://vjudge.net/contest/66964#problem/C

题目:

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.
One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.
For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

InputThe input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
OutputFor each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5
Sample Output
2
4
题意:说有n个人要来参加生日聚会,认识的人坐在一个桌上,如果A->B,B->C,那么ABC坐在一个桌上,求有多少个桌子
思路:找每个人的“爸爸”即可,看有多少个“爸爸”就是有多少个桌子辽,用set存储“爸爸”即可,输出st.size(),即就是答案,注意下标从1开始,一开始俺从0开始俺就WA了一发
//
// Created by hy on 2019/7/23.
//
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include<set>using namespace std;
const int maxn=3e4+10;
int father[maxn];
int find(int x)
{
    if(x==father[x])
        return x;
    return father[x]=find(father[x]);
}
void merge(int x,int y)
{
    int xx=find(x);
    int yy=find(y);
    if(xx!=yy)
        father[xx]=yy;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
            father[i]=i;
        int x,y;
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&x,&y);
            merge(x,y);
        }
        set<int>st;
        for(int i=1;i<=n;i++)
        {
            int cun=find(i);
            st.insert(cun);
        }
        printf("%d\n",st.size());
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值