1059 Prime Factors

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p​1​​​k​1​​​​×p​2​​​k​2​​​​×⋯×p​m​​​k​m​​​​.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p​1​​^k​1​​*p​2​​^k​2​​**p​m​​^k​m​​, where p​i​​'s are prime factors of N in increasing order, and the exponent k​i​​ is the number of p​i​​ -- hence when there is only one p​i​​, k​i​​ is 1 and must NOT be printed out.

Sample Input:

97532468

Sample Output:

97532468=2^2*11*17*101*1291
#include <iostream>
#include <vector>
#include <math.h>
#include <algorithm>
#include <map>
#include <sstream>
#include <string.h>

using namespace std;

typedef long long ll;

struct l
{
    ll prime=0;
    ll num=0;
} ;

vector<l> primes;

bool check(ll n)
{
    if(n==1)
        return false;
    if(n==2||n==3)
        return true;
    for(int i=2; i<=sqrt(n); i++)
    {
        if(n%i==0)
            return false;
    }
    return true;
}
int main()
{
    ll n,m;
    cin>>n;
    m=n;
    for(ll i=2; i<=sqrt(n); i++)
    {
        if(check(i)==false)
            continue;
        if(n%i==0)
        {
            l ls;
            ls.prime=i;
            ls.num=1;
            n/=i;
            while(n%i==0)
            {
                ls.num++;
                n/=i;
            }
            primes.push_back(ls);
        }
    }
    if(n!=1||m==1)
    {
        l ls;
        ls.prime=n;
        ls.num=1;
        primes.push_back(ls);
    }
    cout<<m<<"=";
    for(ll i=0;i<primes.size();i++)
    {

            cout<<primes[i].prime;
            if(primes[i].num>1)
                cout<<"^"<<primes[i].num;
            if(i!=primes.size()-1)
            {
                cout<<"*";
            }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值