POJ - 3061:Subsequence(尺取)

原题链接
A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.
Input
The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.
Output
For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input
2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5
Sample Output
2
3

题目描述

给你n个数字,要求你在这些数字中,找出一段连续的且这些数字和大于等于s的最小长度
思路:尺取 - 可以和队列一样的操作,先入队,当入队数字的和大于等于s时,与之前ans(最小长度)进行判断,然后最后一个元素出队,重复上述操作
代码如下

#include <stdio.h>
#include <iostream>
#include <algorithm>

using namespace std;

int a[100005],n;

int main()
{
    int i,j,T,ans,s,sum;//sum记录数字和与s进行判断、ans记录最短长度
    cin >> T;
    while(T--)
    {
        cin >> n >> s;
        for(i = 0;i < n;i++)
            cin >> a[i];
        ans = INT_MAX;
        i = j = sum = 0;
        while(1)
        {
        	//如果数组数组没有加完且总和小于s,循环继续
            while(j < n && sum < s)
                sum += a[j++];
            //如果入队数字加完之后都小于s,那么剩下的数组就没必要尺取了
            if(sum < s)
                break;
            //不断更新最小长度
            ans = min(ans, j - i);
            //将每次入队的最后一个元素出队
            sum -= a[i++];
        }
        if(ans > n)
            ans = 0;
        cout << ans << endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值