原题链接
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world v). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can’t leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
Output
The output contains a string “No.” if you can’t exchange O2 to O1, or you should output a line contains “Yes.”, and then output your way in exchanging the order(you should output “in” for a train getting into the railway, and “out” for a train getting out of the railway). Print a line contains “FINISH” after each test case. More details in the Sample Output.
Sample Input
3 123 321
3 123 312
Sample Output
Yes.
in
in
in
out
out
out
FINISH
No.
FINISH
题目描述
将a序列转换为b序列,如果可以就输出入栈、出栈操作,不可以就输出no
思路:最基础的栈类型的题,分别将两个序列存入两个数组,如果两个序列从下标0的元素开始不同,那么就入栈,相同就出栈,如果操作完了之后,出栈顺序满足序列2(即记录序列2的下标等于n(序列中数字的个数)),那么就可以转换,否则就不能
代码如下
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <stack>
using namespace std;
stack<char> st;
char a[1000];//序列1
char b[1000];//序列2
int sx[1000];//记录入栈还是出栈操作
int main()
{
int i,j,k,n,len1,len2;
while(~scanf("%d %s %s",&n,a,b))
{
j = k = 0;
memset(sx, 0, sizeof(sx));
//清空栈
while(!st.empty())
st.pop();
len1 = strlen(a);
len2 = strlen(b);
for(i = 0;i < len1;i++)
{
//先入栈
st.push(a[i]);
sx[j++] = 1;
//如果栈顶元素与序列2下标k的相同,那么就出栈
while(!st.empty() && st.top() == b[k])
{
st.pop();
sx[j++] = -1;
k++;
}
}
if(k == n)
{
printf("Yes.\n");
for(i = 0;i < j;i++)
{
if(sx[i] == 1)
printf("in\n");
else
printf("out\n");
}
printf("FINISH\n");
}
else
{
printf("No.\n");
printf("FINISH\n");
}
}
return 0;
}