POJ - 1564:Sum It Up(DFS + 输出路径 + 去重)

题目链接
Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t = 4, n = 6, and the list is [4, 3, 2, 2, 1, 1], then there are four different sums that equal 4: 4, 3+1, 2+2, and 2+1+1. (A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.
Input
The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x 1 , . . . , x n . If n = 0 it signals the end of the input; otherwise, t will be a positive integer less than 1000, n will be an integer between 1 and 12 (inclusive), and x 1 , . . . , x n will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.
Output
For each test case, first output a line containing Sums of’, the total, and a colon. Then output each sum, one per line; if there are no sums, output the line `NONE’. The numbers within each sum must appear in nonincreasing order. A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distinct; the same sum cannot appear twice.
Sample Input
4 6 4 3 2 2 1 1
5 3 2 1 1
400 12 50 50 50 50 50 50 25 25 25 25 25 25
0 0
Sample Output
Sums of 4:
4
3+1
2+2
2+1+1
Sums of 5:
NONE
Sums of 400:
50+50+50+50+50+50+25+25+25+25
50+50+50+50+50+25+25+25+25+25+25

题目描述

给出数字t,n个数字,求这些数字和等于t的算式,算式中的数字必须按照给出的数字顺序打印出来,并且每个算式中数字出现次数小于等于给出数字出现的次数

思路:要输出路径就需要一个数组记录,关键就是去重,我们可以在每次循环是提前定义一个变量last来存储上一次的数字,如果与last相同,那么就跳过搜索下一个数字,这样就可以避免出现相同算式

例如:上面案例中求和为400的算式,当我们深搜完第一个算式之后,就会不断返回,直到last和下一数字不相同时,又开始搜索新的算式
上面第一个算式中在倒数第一个50记录了last=50,那么在第二个算式中,下一个数字是25(第一个25),那么就满足搜素条件,就会开始新的搜索

代码如下

#include <stdio.h>
#include <iostream>
#include <algorithm>

using namespace std;

int t,n,flag,a[20],b[20];

void dfs(int s, int k, int g)
{
    int i;
    if(s > t)
        return;
    if(s == t)		//满足条件输出路径
    {
        flag = 1;	//找到结果
        for(i = 0;i < g-1;i++)
            printf("%d+",b[i]);
        printf("%d\n",b[g-1]);
        return;
    }
    int last = -1;
    for(i = k;i < n;i++)
    {
        if(s + a[i] > t)
            continue;
        if(a[i] != last)
        {
            last = b[g] = a[i];		//记录last开始下一轮的试探
            dfs(s+a[i], i+1, g+1);
        }
    }
}

int main()
{
    int i;
    while(~scanf("%d %d",&t,&n) && n)
    {
        flag = 0;
        for(i = 0;i < n;i++)
            scanf("%d",&a[i]);
        printf("Sums of %d:\n",t);
        dfs(0, 0, 0);
        if(!flag)
            printf("NONE\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值