MOOC数据结构课程 题集07 List Leaves

03-树2 List Leaves (25 分)

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves' indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

4 1 5

要求按照从上到下从做到右的顺序输出叶子节点

#include <iostream>

#define MAX_SIZE 10
#define Tree int
//#define ElementType int

typedef struct _Tree_node {
//	int index;
	Tree Left;
	Tree Right;
}Tree_node;

Tree_node  BTree[MAX_SIZE];

using namespace	 std;

Tree build_tree(Tree_node []);
void print_leaves(Tree_node T[], Tree root);

int main()
{
	Tree Root;
	Root = build_tree(BTree);
	print_leaves(BTree, Root);

	return 0;
}

Tree build_tree(Tree_node T[])
{
	int N;
	cin >> N;
	char left, right;
	char is_child[MAX_SIZE] = { 0 };
	for (int i = 0; i < N; i++)
	{
		cin >> left >> right;
		if (left != '-')
		{
			T[i].Left = left - '0';
			is_child[T[i].Left] = 1;
		}
		else T[i].Left = -1;
		if (right != '-')
		{
			T[i].Right = right - '0';
			is_child[T[i].Right] = 1;
		}
		else T[i].Right = -1;
	}

	int root;
	for (root = 0; root < N; root++)
	{
		if (is_child[root] == 0)
			break;
	}

	return root;
}

void print_leaves(Tree_node T[], Tree root)
{
	Tree T_queue[MAX_SIZE+1];
	int front = 0, rear = 0;
	int flag = 0;

	T_queue[rear++] = root;
	while (front != rear)
	{
		if (T[T_queue[front]].Left == -1 && T[T_queue[front]].Right == -1)
		{
			if (flag == 0)
			{
				cout << T_queue[front];
				flag++;
			}
			else cout << " " << T_queue[front];
		}
		else
		{
			if (T[T_queue[front]].Left != -1)
				T_queue[rear++] = T[T_queue[front]].Left;

			if (T[T_queue[front]].Right != -1)
				T_queue[rear++] = T[T_queue[front]].Right;
		}
		front++;
	}
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值