D - 破损的键盘 (p143, 链表) 紫数 P143 STL库

You’re typing a long text with a broken keyboard. Well it’s not so badly broken. The only problem with the keyboard is that sometimes the “home” key or the “end” key gets automatically pressed (internally). You’re not aware of this issue, since you’re focusing on the text and did not even turn on the monitor! After you finished typing, you can see a text on the screen (if you turn on the monitor). In Chinese, we can call it Beiju. Your task is to find the Beiju text.

 

Input

There are several test cases. Each test case is a single line containing at least one and at most 100,000 letters, underscores and two special characters ‘[’ and ‘]’. ‘[’ means the “Home” key is pressed internally, and ‘]’ means the “End” key is pressed internally. The input is terminated by end-of-file (EOF).

Output

For each case, print the Beiju text on the screen.

Sample Input

This_is_a_[Beiju]_text

[[]][][]Happy_Birthday_to_Tsinghua_University

 

Sample Output

BeijuThis_is_a__text

Happy_Birthday_to_Tsinghua_University

 

你在输入文章的时候,键盘上的Home键和End键出了问题,会不定时的按下。你却不知道此问题,而是专心致志地打稿子,甚至显示器都没开。当你打开显示器之后,展现你面前的数一段悲剧文本。你的任务是在显示器打开前计算出这段悲剧的文本。 给你一段按键的文本,其中'['表示Home键,']'表示End键,输入结束标志是文件结束符(EOF)。

输出一行,即这段悲剧文本

 

思路 : STL库list 完美模拟链表,真香;

遍历字符串遇到 "["  前插 遇到 "]" h后插 注意前插的时候一定要反着来,一定要判断是不是最后一个 "[" && "]" 是的话让他直接f变为 l

下面是AC代码

#include<iostream>
#include<stdio.h>
#include<queue>
#include<string.h>
#include<algorithm>
#include<string>
#include<stack>
#include<list>
#define ll long long
using namespace std;
int main()
{
	char a[100005];
	while(cin>>a)
	{
		list<char> L;
		int l = strlen(a) ;
		for(int i = 0 ; i < l ; i++)
		{
			if(a[i] != '[' && a[i] != ']')
			{
				L.push_back(a[i]);
				
			}
			if(a[i] == '[')
			{
				int data = i ;
				int f = 0 ;
				for(int j =data + 1 ; j < l ; j++)
				{
					if(a[j] == '[' || a[j] == ']')
					{
						f = j ;
						break;
					}
				}
				if(f == 0 )
				{
					f = l ;
				}
				for(int j = f-1 ; j>data ; j--)
				{
					L.push_front(a[j]);
					i++;
				
				} 
			}
			if(a[i] == ']')
			{
				int f = 0 ;
				for(int j =i + 1 ; j < l ; j++)     
				{
					if(a[j] == '[' || a[j] == ']')
					{
						f = j ;
						break;
					}
				}
				if( f == 0 )
				{
					f = l ;
				}
				for(int j = i+1  ;  j < f ; j++)
				{
					L.push_back(a[j]);
					i++;
				} 				
			}
		}
		while(!L.empty())
		{
			cout<<L.front();
			L.pop_front() ;
		}
		cout<<endl;
	}
	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值