Constructing Roads(最小生成树) POJ 2421

POJ 2421

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179

分析

这题表面上告诉了各点之间的距离矩阵,是稠密图,但是已经有了一些现成的路,所以已连接的路并不只是一个集合(一个树),用一般prim方法不方便解决问题,考虑到数据不是很大,可以采用O(n^2logn) (n是点的个数)的kruskal算法

kruskal算法(加边法):
  1. 把图中的所有边按代价从小到大排序
  2. 把图中的n个顶点看成独立的n棵树组成的森林
  3. 按权值从小到大选择边,所选的边连接的两个顶点u,v。u,v应属于两棵不同的树,则成为最小生成树的一条边,并将这两颗树合并作为一棵树
  4. 重复(3),直到所有顶点都在一颗树内或者有n-1条边为止。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <set>
using namespace std;
int dis[105][105];
int pre[10050];
struct node {
	int f, t, d;//路的起点,终点和距离 
}rode[10050];

int find(int x) {
	return x == pre[x] ? x : pre[x] = find(pre[x]);//寻找父节点,同时路径压缩 
}
bool cmp(node a, node b)
{
	return a.d < b.d;
}

int main()
{
	int n, q, a, b, i, j;
	int count = 0, null;
	int sum = 0, time;
	scanf("%d", &n);
	for (i = 1; i <= n; i++) {
		for (j = 1; j <= n; j++) {
			if (j > i) {//两点间只读入一次路 
				scanf("%d", &rode[count].d);
				rode[count].f = i;
				rode[count].t = j;
				count++;
			}
			else scanf("%d", &null);
		}
	}
	for (i = 1; i <=n; i++)
		pre[i] = i;
	sort(rode, rode + count, cmp);//总共有count条路 
	scanf("%d", &q);
	int temp = 0;
	for (i = 0; i < q; i++)
	{
		scanf("%d%d", &a, &b);
		int u = find(a), v = find(b);
		if (u != v)
		{
			temp++;
			pre[u] = v;
		}
	}
	time = n - 1 - temp ;
	for (i = 0; i < count; i++)
	{
		int u = find(rode[i].f);
		int v = find(rode[i].t);
		if (u != v)//起点与终点不在同一颗树中 
		{
			pre[u] = v;
			time--;
			sum += rode[i].d;
			if (time == 0) break;
		}
	}
	printf("%d\n", sum);
}

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值