B - Network

题目链接:https://vjudge.net/contest/327529#problem/B

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connectingseveral places numbered by integers from 1 toN. No two places have the same number. The linesare bidirectional and always connect together two places and in each place the lines end in a telephoneexchange. There is one telephone exchange in each place. From each place it is possible to reachthrough lines every other place, however it need not be a direct connection, it can go through severalexchanges. From time to time the power supply fails at a place and then the exchange does not operate.The officials from TLC realized that in such a case it can happen that besides the fact that the placewith the failure is unreachable, this can also cause that some other places cannot connect to each other.In such a case we will say the place (where the failure occured) is critical. Now the officials are tryingto write a program for finding the number of all such critical places. Help them.

input

The input file consists of several blocks of lines. Each block describes one network. In the first lineof each block there is the number of placesN<100. Each of the next at mostNlines contains thenumber of a place followed by the numbers of some places to which there is a direct line from this place.These at mostNlines completely describe the network, i.e., each direct connection of two places inthe network is contained at least in one row. All numbers in one line are separated by one space. Eachblock ends with a line containing just ‘0’. The last block has only one line withN= 0.

output

The output contains for each block except the last in the input file one line containing the number ofcritical place。

Sample Input

5

5 1 2 3 4

0

6

2 1 3

5 4 6 2

0

0

Sample Output

1

2

简单的求割点的算法,直接套模板就好
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#include<stdlib.h>
#include<vector>
using namespace std;
vector<int>q[1005];
int low[1005];
int dfn[1005];
int vis[1005];
int cut[1005];
int tot;
int root;
void init()
{
    memset(low,0,sizeof(low));
    memset(dfn,0,sizeof(dfn));
    memset(vis,0,sizeof(vis));
    memset(cut,0,sizeof(cut));
    for(int i=0;i<=101;i++)
    {
        q[i].clear();
    }
    tot=0;
    root=1;
}
void add(int x,int y)
{
    q[x].push_back(y);
}
void trajan(int x,int y)
{
    int son=0;
    vis[x]=1;
    dfn[x]=low[x]=++tot;
    for(int i=0;i<q[x].size();i++)
    {
        int v=q[x][i];
        if(vis[v]==1&&v!=y)
        {
            low[x]=min(low[x],dfn[v]);
        }
        if(vis[v]==0)
        {
            trajan(v,y);
            son++;
            low[x]=min(low[v],low[x]);
            if(x==root&&son>1||(x!=root&&low[v]>=dfn[x]))
            {
                cut[x]=1;
            }
        }
        
    }
    vis[x]=2;
}
int main()
{
   int n,k;
   while(~scanf("%d",&n)&&n)
   {
       init();
     while(~scanf("%d",&k)&&k)
     {
         while(getchar()!='\n')
         {
             int a;
             scanf("%d",&a);
             add(a,k);
             add(k,a);
         }
     }
     trajan(1,-1);
     int ans=0;
     for(int i=1;i<=n;i++)
     {
         if(cut[i])
         {
             ans++;
         }
     }
     printf("%d\n",ans);
   }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值