Toy Storage

题目链接

题目

Mom and dad have a problem: their child, Reza, never puts his toys away when he is finished playing with them. They gave Reza a rectangular box to put his toys in. Unfortunately, Reza is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for Reza to find his favorite toys anymore.
Reza’s parents came up with the following idea. They put cardboard partitions into the box. Even if Reza keeps throwing his toys into the box, at least toys that get thrown into different partitions stay separate. The box looks like this from the top:
We want for each positive integer t, such that there exists a partition with t toys, determine how many partitions have t, toys.

Input

The input consists of a number of cases. The first line consists of six integers n, m, x1, y1, x2, y2. The number of cardboards to form the partitions is n (0 < n <= 1000) and the number of toys is given in m (0 < m <= 1000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1, y1) and (x2, y2), respectively. The following n lines each consists of two integers Ui Li, indicating that the ends of the ith cardboard is at the coordinates (Ui, y1) and (Li, y2). You may assume that the cardboards do not intersect with each other. The next m lines each consists of two integers Xi Yi specifying where the ith toy has landed in the box. You may assume that no toy will land on a cardboard.

A line consisting of a single 0 terminates the input.

Output

For each box, first provide a header stating “Box” on a line of its own. After that, there will be one line of output per count (t > 0) of toys in a partition. The value t will be followed by a colon and a space, followed the number of partitions containing t toys. Output will be sorted in ascending order of t for each box.

Sample Input
4 10 0 10 100 0
20 20
80 80
60 60
40 40
5 10
15 10
95 10
25 10
65 10
75 10
35 10
45 10
55 10
85 10
5 6 0 10 60 0
4 3
15 30
3 1
6 8
10 10
2 1
2 8
1 5
5 5
40 10
7 9
0

Sample Output

Box
2: 5
Box
1: 4
2: 1

题目大意
给你一个矩形,然后给你n条线段,然后这n条线段把这个矩形分解成了n+1个区域。然后再给你m个玩具(每个玩具的坐标给出),让你判断有x个玩具的区间有几个(x是从1到m,有玩具的话就输出,没玩具就算了)。
输出按照区间玩具数量升序排序。
思路
这个与上一个题不太相同的地方就是,这个没有给你按顺序给出,然后你要先排序,然后才叉积,最后总结按具有相同玩具的区间个数升序输出就好。
AC

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
struct zxc
{
    double q,h;
}a[1005];
int c[1005];
double b[1005][2];
int ans[10005];
bool cmp(zxc e,zxc w)
{
    if(e.q==w.q)
    {
        return e.h<w.h;
    }
    return e.q<w.q;
}
int main()
{
    int n,m;
   double x1,y1,x2,y2;
    while(scanf("%d",&n))
    {
        int t=0;

        if(n==0)
        {
            break;
        }
        scanf("%d%lf%lf%lf%lf",&m,&x1,&y1,&x2,&y2);
         int num=m;
        for(int i=1;i<=n;i++)
        {
            scanf("%lf%lf",&a[i].h,&a[i].q);
        }
       sort(a+1,a+1+n,cmp);
        for(int i=1;i<=m;i++)
        {
            scanf("%lf%lf",&b[i][0],&b[i][1]);
        }
        int w=0;
        for(int i=1;i<=n;i++)
        {
            w=0;
            for(int j=1;j<=m;j++)
            {
                if((a[i].h-a[i].q)*(b[j][1]-y2)-(y1-y2)*(b[j][0]-a[i].q)<0)
                {
                    w++;
                }
            }
            ans[i-1]=num-w;
            num=w;
        }
        ans[n]=w;
        printf("Box\n");
        memset(c,0,sizeof(c));
        for(int i=0;i<=n;i++)
        {
            if(ans[i])
            {
                c[ans[i]]++;
            }
        }

        for(int i=1;i<=n;i++)
        {
            if(c[i])
            {
                printf("%d: %d\n",i,c[i]);
            }
        }
//        for(int i=0;i<=n;i++)
//        {
//            printf("%d: %d\n",i,ans[i]);
//        }
//        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值