HDU1171 Big Event in HDU (多重背包模板)

Decsription

Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.

Output

For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.

Sample Input

2
10 1
20 1
3
10 1
20 2
30 1
-1

Sample Output

20 10
40 40

解析:

为了保证公平我们应该使得两个人的值最终尽可能的相等,那么我们就将整个能量的和对半分,这也就是他们的背包容量的上限。

在最大可能公平的情况下,进行多重背包的求解,最终求得实际的最大值。

AC代码:

#include <bits/stdc++.h>
using namespace std;

struct node
{
    int x, y;
    node(int x, int y) : x(x), y(y) {}
};
const int maxn = 3e5 + 5;
int a[maxn], n, dp[maxn];
int x, y;
vector<node> g;

void complete_pack(const int &value, const int &weight, const int &size)
{
    for(int i = weight; i <= size; i++)
        dp[i] = max(dp[i], dp[i - weight] + value);
}

void zero_pack(const int &value, const int &weight, const int &size)
{
    for(int i = size; i >= weight; i--)
        dp[i] = max(dp[i], dp[i - weight] + value);
}

void mutiple_pack(const int &value, const int &weight, const int &num, const int &size)
{
    if(value * num >= size)
        complete_pack(value, weight, size);
    else
    {
        int k = 1, n = num;
        while(k <= n)
        {
            zero_pack(value * k, k * weight, size);
            n -= k;
            k *= 2;
        }
        if(n > 0)
            zero_pack(n * value, n * weight, size);
    }
}

int main()
{
    while(scanf("%d", &n) != EOF && n > 0)
    {
        int sum = 0;
        g.clear();
        for(int i = 0; i < n; i++)
        {
            scanf("%d%d", &x, &y);
            sum += x * y;
            g.push_back(node(x, y));
        }

        int size = sum / 2;
        memset(dp, 0, sizeof dp);

        for(int i = 0; i < n; i++)
            mutiple_pack(g[i].x, g[i].x, g[i].y, size);

        int res = sum - dp[size] > dp[size] ? sum - dp[size] : dp[size];
        printf("%d %d\n", res, sum - res);
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值