最短路dijktra—Tram(POJ-1847)

题目链接:>_>

题目:Tram

Tram network in Zagreb consists of a number of intersections and rails connecting some of them. In every intersection there is a switch pointing to the one of the rails going out of the intersection. When the tram enters the intersection it can leave only in the direction the switch is pointing. If the driver wants to go some other way, he/she has to manually change the switch.

When a driver has do drive from intersection A to the intersection B he/she tries to choose the route that will minimize the number of times he/she will have to change the switches manually.

Write a program that will calculate the minimal number of switch changes necessary to travel from intersection A to intersection B.

Input

The first line of the input contains integers N, A and B, separated by a single blank character, 2 <= N <= 100, 1 <= A, B <= N, N is the number of intersections in the network, and intersections are numbered from 1 to N.

Each of the following N lines contain a sequence of integers separated by a single blank character. First number in the i-th line, Ki (0 <= Ki <= N-1), represents the number of rails going out of the i-th intersection. Next Ki numbers represents the intersections directly connected to the i-th intersection.Switch in the i-th intersection is initially pointing in the direction of the first intersection listed.

Output

The first and only line of the output should contain the target minimal number. If there is no route from A to B the line should contain the integer “-1”.

Sample Input

3 2 1
2 2 3
2 3 1
2 1 2

Sample Output

0

题意:

n个点嘛,然后同时n个边嘛。然后求a到b的最小改变方向的次数

AC代码:

#include<queue>
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
using namespace std;

#define ll long long
#define itn int
const int maxn = 0x73f3f3f;
int cnt, head[10005],foot[10005];
struct node {
	int to,next, w;
}x[10005];

void add(int start, int endd, int w) {
	x[cnt].w = w;
	x[cnt].to = endd;
	x[cnt].next = head[start];
	head[start] = cnt++;
}


void init() {
	cnt = 0;
	memset(head, -1, sizeof head);
	memset(x, 0, sizeof x);
	memset(foot, maxn, sizeof foot);
}

priority_queue<node>q;
bool operator <(node a, node b) {
	return a.w > b.w;
}

int main() {
	init();
	int n, a, b;
	scanf("%d %d %d", &n, &a, &b);
	int i, j;
	int q1, q2;
	for (i = 1; i <= n; i++) {
		int k = 0;
		scanf("%d", &k);
		for (j = 0; j < k; j++) {
			scanf("%d", &q1);
			if (j == 0) add(i, q1, 0);
			else add(i, q1, 1);
		}
	}
	node z = { a,0,0 };
	q.push(z);
	foot[a] = 0;
	while (!q.empty()) {
		z = q.top();
		q.pop();
		int start = z.to;
		for (i = head[start]; i != -1; i = x[i].next) {
			int endd = x[i].to;
			if (foot[endd] > foot[start] + x[i].w) {
				foot[endd] = foot[start] + x[i].w;
				q.push(x[i]);
			}
		}
	}
	if(foot[b] < maxn)cout << foot[b] << endl;
	else cout << "-1" << endl;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值